summaryrefslogtreecommitdiff
path: root/package/flex
diff options
context:
space:
mode:
authorDanomi Manchego <danomimanchego123@gmail.com>2014-07-28 21:35:34 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-29 23:54:22 +0200
commitdd70b3b7531ca8cabb5aadcd52606172bf187e50 (patch)
tree45c77bddadcbd05f6feef951e98d5ceddd353532 /package/flex
parent025d4a17298e85e6efad42bdde619e47bb78ba20 (diff)
flex: delete broken flex++ symlink from target
When flex is built for the target without installing the flex binary, a flex++ symlink installed by flex's Makefile points to the missing flex executable. This mod adds a post target install hook to remove the broken symlink. Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/flex')
-rw-r--r--package/flex/flex.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/flex/flex.mk b/package/flex/flex.mk
index 17f651b80..cd92dd7b0 100644
--- a/package/flex/flex.mk
+++ b/package/flex/flex.mk
@@ -29,6 +29,12 @@ define FLEX_DISABLE_PROGRAM
endef
FLEX_POST_PATCH_HOOKS += FLEX_DISABLE_PROGRAM
+# flex++ symlink is broken when flex binary is not installed
+define FLEX_REMOVE_BROKEN_SYMLINK
+ rm -f $(TARGET_DIR)/usr/bin/flex++
+endef
+FLEX_POST_INSTALL_TARGET_HOOKS += FLEX_REMOVE_BROKEN_SYMLINK
+
endif
$(eval $(autotools-package))