summaryrefslogtreecommitdiff
path: root/package/flickcurl
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-28 23:26:53 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-28 23:26:53 +0200
commit563f586e9abd018b3cc348f0e6de78dfc3a54911 (patch)
tree622ee4b6abf5366cc29854a30ebccda92044b6d9 /package/flickcurl
parent58441cfd482813a7d7610d2c87dd94bc385795a0 (diff)
flickcurl: adjust openssl dependency
flickcurl does not specifically need openssl: it needs libcurl to have crypto support to access https:// URLs. So, instead of depending on openssl in FLICKCURL_DEPENDENCIES, this commit simply leaves it to the Config.in file to select either OpenSSL, gnutls or libnss to make sure libcurl will use one of these libraries. Reported-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/flickcurl')
-rw-r--r--package/flickcurl/Config.in2
-rw-r--r--package/flickcurl/flickcurl.mk2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/flickcurl/Config.in b/package/flickcurl/Config.in
index 7b917107f..426ceecba 100644
--- a/package/flickcurl/Config.in
+++ b/package/flickcurl/Config.in
@@ -2,6 +2,8 @@ config BR2_PACKAGE_FLICKCURL
bool "flickcurl"
select BR2_PACKAGE_LIBCURL
select BR2_PACKAGE_LIBXML2
+ # Ensure that libcurl is built with crypto support, since
+ # flickcurl must access https:// URLs.
select BR2_PACKAGE_OPENSSL if !(BR2_PACKAGE_GNUTLS || BR2_PACKAGE_LIBNSS)
select BR2_PACKAGE_CA_CERTIFICATES # runtime
help
diff --git a/package/flickcurl/flickcurl.mk b/package/flickcurl/flickcurl.mk
index 67e88518f..43027453a 100644
--- a/package/flickcurl/flickcurl.mk
+++ b/package/flickcurl/flickcurl.mk
@@ -11,7 +11,7 @@ FLICKCURL_LICENSE_FILES = COPYING COPYING.LIB LICENSE-2.0.txt LICENSE.html
FLICKCURL_INSTALL_STAGING = YES
FLICKCURL_CONFIG_SCRIPTS = flickcurl-config
FLICKCURL_CONF_OPT = --without-curl-config --without-xml2-config --without-raptor
-FLICKCURL_DEPENDENCIES = libcurl libxml2 openssl host-pkgconf
+FLICKCURL_DEPENDENCIES = libcurl libxml2 host-pkgconf
ifeq ($(BR2_PACKAGE_FLICKCURL_UTILS),)
define FLICKCURL_REMOVE_UTILS