summaryrefslogtreecommitdiff
path: root/package/fluxbox
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-11-30 15:18:50 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-12-02 00:27:58 +0100
commit82f82117eeebb2694565d26c1d76019823c7c057 (patch)
tree4c72c7a14d42e7b6386512f8f614fe0b9e168940 /package/fluxbox
parent19c8fa96b5a1396c49abe21efda8a31b9a743816 (diff)
fluxbox: install session file unconditionally
As discussed, users should use a rootfs overlay or a post-build script instead of a custom skeleton to override files installed by Buildroot, so there is no point in having conditions when installing init scripts or configuration files. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/fluxbox')
-rw-r--r--package/fluxbox/fluxbox.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/fluxbox/fluxbox.mk b/package/fluxbox/fluxbox.mk
index 21901d619..a0f93672e 100644
--- a/package/fluxbox/fluxbox.mk
+++ b/package/fluxbox/fluxbox.mk
@@ -24,8 +24,8 @@ FLUXBOX_CONF_OPTS += --disable-imlib2
endif
define FLUXBOX_INSTALL_XSESSION_FILE
- [ -f $(TARGET_DIR)/root/.xsession ] || $(INSTALL) -m 0755 -D \
- package/fluxbox/xsession $(TARGET_DIR)/root/.xsession
+ $(INSTALL) -m 0755 -D package/fluxbox/xsession \
+ $(TARGET_DIR)/root/.xsession
endef
FLUXBOX_POST_INSTALL_TARGET_HOOKS += FLUXBOX_INSTALL_XSESSION_FILE