summaryrefslogtreecommitdiff
path: root/package/fmlib
diff options
context:
space:
mode:
authorMatt Weber <matthew.weber@rockwellcollins.com>2014-06-10 19:50:28 -0700
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-06-14 18:55:18 +0200
commit68d35f7d92d40f8d470751269e6ee9e398b15a1e (patch)
tree1621d4a2faa274814a8183ddb710f5804b548853 /package/fmlib
parent5e27a98b4d177f338500ebcb426232a17f695799 (diff)
fmlib: new package
Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/fmlib')
-rw-r--r--package/fmlib/Config.in14
-rw-r--r--package/fmlib/fmlib.mk36
2 files changed, 50 insertions, 0 deletions
diff --git a/package/fmlib/Config.in b/package/fmlib/Config.in
new file mode 100644
index 000000000..f9b09c6f7
--- /dev/null
+++ b/package/fmlib/Config.in
@@ -0,0 +1,14 @@
+comment "fmlib needs a Linux kernel to be built"
+ depends on !BR2_LINUX_KERNEL
+
+config BR2_PACKAGE_FMLIB
+ bool "fmlib"
+ depends on BR2_powerpc_e500mc
+ depends on BR2_LINUX_KERNEL
+ help
+ The Frame Manager library provides Freescale PowerPC platforms an
+ API on top of the Frame Manager driver ioctl calls, that provides
+ a user space application with a simple way to configure driver
+ parameters and PCD (parse - classify - distribute) rules.
+
+ http://git.freescale.com/git/cgit.cgi/ppc/sdk/fmlib.git/tree/README
diff --git a/package/fmlib/fmlib.mk b/package/fmlib/fmlib.mk
new file mode 100644
index 000000000..8fca0cd3a
--- /dev/null
+++ b/package/fmlib/fmlib.mk
@@ -0,0 +1,36 @@
+#############################################################
+#
+# fmlib
+#
+#############################################################
+
+FMLIB_VERSION = fsl-sdk-v1.5-rc3
+FMLIB_SITE = git://git.freescale.com/ppc/sdk/fmlib.git
+FMLIB_LICENSE = BSD-3c GPLv2+
+FMLIB_LICENSE_FILES = COPYING
+FMLIB_DEPENDENCIES = linux
+FMLIB_INSTALL_STAGING = YES
+
+# This package installs a static library only, so there's
+# nothing to install to the target
+FMLIB_INSTALL_TARGET = NO
+
+FMLIB_MAKE_OPTS = \
+ CC="$(TARGET_CC)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ KERNEL_SRC="$(LINUX_DIR)" \
+ PREFIX="$(STAGING_DIR)/usr"
+
+ifeq ($(BR2_powerpc_e500mc),y)
+ FMLIB_ARCHTYPE = ppce500mc
+endif
+
+define FMLIB_BUILD_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE) $(FMLIB_MAKE_OPTS) -C $(@D) libfm-$(FMLIB_ARCHTYPE).a
+endef
+
+define FMLIB_INSTALL_STAGING_CMDS
+ $(FMLIB_MAKE_ENV) $(MAKE) $(FMLIB_MAKE_OPTS) -C $(@D) install-libfm-$(FMLIB_ARCHTYPE)
+endef
+
+$(eval $(generic-package))