summaryrefslogtreecommitdiff
path: root/package/font-awesome
diff options
context:
space:
mode:
authorAtul Singh <atul.singh.mandla@rockwellcollins.com>2016-02-17 15:26:52 +0530
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 15:38:56 +0100
commit4f6ba8cd458e3fa78789c8848493712b8574a294 (patch)
tree24e01276b3b0e80898fe103c236ea3bbe1ccf286 /package/font-awesome
parent1ded02f0b2cdad55a554e7d438fa9f2bd1fe4059 (diff)
font-awesome:new package
Font Awesome is a full suite of 605 pictographic icons for easy scalable vector graphics on websites. Signed-off-by: Atul Singh <atul.singh.mandla@rockwellcollins.com> [Thomas: fix misc minor typos.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/font-awesome')
-rw-r--r--package/font-awesome/Config.in7
-rw-r--r--package/font-awesome/font-awesome.hash2
-rw-r--r--package/font-awesome/font-awesome.mk18
3 files changed, 27 insertions, 0 deletions
diff --git a/package/font-awesome/Config.in b/package/font-awesome/Config.in
new file mode 100644
index 000000000..694d74e5a
--- /dev/null
+++ b/package/font-awesome/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_FONT_AWESOME
+ bool "font-awesome"
+ help
+ Font Awesome is a full suite of 605 pictographic icons for
+ easy scalable vector graphics on websites.
+
+ https://github.com/FortAwesome/Font-Awesome
diff --git a/package/font-awesome/font-awesome.hash b/package/font-awesome/font-awesome.hash
new file mode 100644
index 000000000..9f3715e5b
--- /dev/null
+++ b/package/font-awesome/font-awesome.hash
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 7813f416057da622b16229b10fef550e1dc64c5bb59871cd38fa86e76dfdbae8 font-awesome-v4.5.0.tar.gz
diff --git a/package/font-awesome/font-awesome.mk b/package/font-awesome/font-awesome.mk
new file mode 100644
index 000000000..6ebb92cc3
--- /dev/null
+++ b/package/font-awesome/font-awesome.mk
@@ -0,0 +1,18 @@
+################################################################################
+#
+# font-awesome
+#
+################################################################################
+
+FONT_AWESOME_VERSION = v4.5.0
+FONT_AWESOME_SITE = $(call github,FortAwesome,Font-Awesome,$(FONT_AWESOME_VERSION))
+FONT_AWESOME_LICENSE = OFLv1.1 (font), MIT (CSS, LESS and Sass files)
+FONT_AWESOME_DIRECTORIES_LIST = css fonts less scss
+
+define FONT_AWESOME_INSTALL_TARGET_CMDS
+ mkdir -p $(TARGET_DIR)/usr/share/font-awesome/
+ $(foreach d,$(FONT_AWESOME_DIRECTORIES_LIST),\
+ cp -dpfr $(@D)/$(d) $(TARGET_DIR)/usr/share/font-awesome$(sep))
+endef
+
+$(eval $(generic-package))