summaryrefslogtreecommitdiff
path: root/package/freescale-imx
diff options
context:
space:
mode:
authorGary Bisson <gary.bisson@boundarydevices.com>2016-07-27 15:53:32 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-08-03 22:06:36 +0200
commit317bcd4c902e466a0ad2c3236f0267ad3d864dac (patch)
treee888174e3c7909d9843a1e14ebb59a18acd899e5 /package/freescale-imx
parent0c112ddd30464930d99b73b471e5173fa0ee81d2 (diff)
imx-parser: add install hooks to fix libraries path
By default, all the libraries are installed under /usr/lib/imx-mm which causes problems at runtime. [Peter: drop -mindepth/-maxdepth, add comment explaining why this is done] Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/freescale-imx')
-rw-r--r--package/freescale-imx/imx-parser/imx-parser.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/freescale-imx/imx-parser/imx-parser.mk b/package/freescale-imx/imx-parser/imx-parser.mk
index a207d6e4f..7dd140249 100644
--- a/package/freescale-imx/imx-parser/imx-parser.mk
+++ b/package/freescale-imx/imx-parser/imx-parser.mk
@@ -20,4 +20,13 @@ endef
# The Makefile installs several versions of the libraries, but we only
# need one of them, depending on the platform.
+# Upstream installs libraries into usr/lib/imx-mm, but the dynamic
+# loader only looks in usr/lib, so move the libraries there
+define IMX_PARSER_FIXUP_TARGET_PATH
+ find $(TARGET_DIR)/usr/lib/imx-mm -not -type d \
+ -exec mv {} $(TARGET_DIR)/usr/lib \;
+ rm -rf $(TARGET_DIR)/usr/lib/imx-mm
+endef
+IMX_PARSER_POST_INSTALL_TARGET_HOOKS += IMX_PARSER_FIXUP_TARGET_PATH
+
$(eval $(autotools-package))