summaryrefslogtreecommitdiff
path: root/package/freescale-imx
diff options
context:
space:
mode:
authorGary Bisson <gary.bisson@boundarydevices.com>2016-02-02 00:38:11 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-02 10:20:46 +0100
commitda4fff547c4c55926cf0c62cf1ebb6a59d5e0347 (patch)
tree0be0c3fcb44ce7353c936a30748f5d4140899415 /package/freescale-imx
parent63abfb7210313fcc84b912ff2884b1357beff4b5 (diff)
kernel-module-imx-gpu-viv: add new package
This is the Vivante kernel driver split from the kernel source code in order to make it possible to be used in any kernel source since 3.10.53. The driver source code provided by Freescale needs fixes so the community forked the code to allow faster development and easier integration of fixes from the community. This patch is based on the Yocto equivalent: https://github.com/Freescale/meta-fsl-arm/commit/32cf391 https://github.com/Freescale/meta-fsl-arm/commit/4249193 This package has been tested with the following commands: # modprobe galcore # cd /usr/share/examples/viv_samples/vdk/ # ./tutorial7 Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/freescale-imx')
-rw-r--r--package/freescale-imx/Config.in1
-rw-r--r--package/freescale-imx/kernel-module-imx-gpu-viv/Config.in14
-rw-r--r--package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.hash2
-rw-r--r--package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.mk20
4 files changed, 37 insertions, 0 deletions
diff --git a/package/freescale-imx/Config.in b/package/freescale-imx/Config.in
index a958dbd44..dfb6cc4a3 100644
--- a/package/freescale-imx/Config.in
+++ b/package/freescale-imx/Config.in
@@ -52,6 +52,7 @@ source "package/freescale-imx/libz160/Config.in"
endif
if BR2_PACKAGE_FREESCALE_IMX_PLATFORM_IMX6Q
source "package/freescale-imx/imx-gpu-viv/Config.in"
+source "package/freescale-imx/kernel-module-imx-gpu-viv/Config.in"
endif
endif
diff --git a/package/freescale-imx/kernel-module-imx-gpu-viv/Config.in b/package/freescale-imx/kernel-module-imx-gpu-viv/Config.in
new file mode 100644
index 000000000..bcc55175b
--- /dev/null
+++ b/package/freescale-imx/kernel-module-imx-gpu-viv/Config.in
@@ -0,0 +1,14 @@
+comment "kernel-module-imx-gpu-viv needs a Linux kernel to be built"
+ depends on !BR2_LINUX_KERNEL
+
+config BR2_PACKAGE_KERNEL_MODULE_IMX_GPU_VIV
+ bool "kernel-module-imx-gpu-viv"
+ depends on BR2_LINUX_KERNEL
+ help
+ Kernel loadable module for Vivante GPU.
+
+ This package uses an exact copy of the GPU kernel driver source code
+ of the same version as base and include fixes and improvements
+ developed by FSL Community
+
+ https://github.com/Freescale/kernel-module-imx-gpu-viv
diff --git a/package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.hash b/package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.hash
new file mode 100644
index 000000000..7d01afbed
--- /dev/null
+++ b/package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.hash
@@ -0,0 +1,2 @@
+# locally computed
+sha256 955037fd86d31cdddaed15c254f377f4b30a8abcf5a5e4f9185bd660ff14b7c3 kernel-module-imx-gpu-viv-eeeb23c0fb1cee01318088d417025263479c44ac.tar.gz
diff --git a/package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.mk b/package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.mk
new file mode 100644
index 000000000..95b0a6bd9
--- /dev/null
+++ b/package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.mk
@@ -0,0 +1,20 @@
+################################################################################
+#
+# kernel-module-imx-gpu-viv
+#
+################################################################################
+
+KERNEL_MODULE_IMX_GPU_VIV_VERSION = eeeb23c0fb1cee01318088d417025263479c44ac
+KERNEL_MODULE_IMX_GPU_VIV_SITE = \
+ $(call github,Freescale,kernel-module-imx-gpu-viv,$(KERNEL_MODULE_IMX_GPU_VIV_VERSION))
+KERNEL_MODULE_IMX_GPU_VIV_LICENSE = GPLv2
+KERNEL_MODULE_IMX_GPU_VIV_LICENSE_FILES = COPYING
+
+KERNEL_MODULE_IMX_GPU_VIV_MODULE_MAKE_OPTS = \
+ AQROOT=$(@D)/kernel-module-imx-gpu-viv-src \
+ KERNEL_DIR=$(LINUX_DIR)
+
+KERNEL_MODULE_IMX_GPU_VIV_MODULE_SUBDIRS = kernel-module-imx-gpu-viv-src
+
+$(eval $(kernel-module))
+$(eval $(generic-package))