summaryrefslogtreecommitdiff
path: root/package/freetype
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2013-10-27 00:44:54 +0200
committerPeter Korsgaard <peter@korsgaard.com>2013-10-27 08:28:13 +0100
commit96f702993cfa4b7e15549faddbc41917663dbe37 (patch)
treed0bc94f0eabc295235e84436f9d2c94b28f1320f /package/freetype
parent9332e26125685c8ba3682516727af96e43e33617 (diff)
freetype: explicitly en/disable dependencies
For the target, add --with/out to configure options as needed. For the host, disable everything. This was triggered by a failing build of the host package because it tried to link the shared library with libbz.a, which isn't compiled with -fPIC. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/freetype')
-rw-r--r--package/freetype/freetype.mk20
1 files changed, 16 insertions, 4 deletions
diff --git a/package/freetype/freetype.mk b/package/freetype/freetype.mk
index 93fb3db82..cc5fbf858 100644
--- a/package/freetype/freetype.mk
+++ b/package/freetype/freetype.mk
@@ -13,13 +13,25 @@ FREETYPE_INSTALL_STAGING = YES
FREETYPE_MAKE_OPT = CCexe="$(HOSTCC)"
FREETYPE_LICENSE = Dual FTL/GPLv2+
FREETYPE_LICENSE_FILES = docs/FTL.TXT docs/GPLv2.TXT
-FREETYPE_DEPENDENCIES = host-pkgconf \
- $(if $(BR2_PACKAGE_ZLIB),zlib) \
- $(if $(BR2_PACKAGE_BZIP2),bzip2)
+FREETYPE_DEPENDENCIES = host-pkgconf
FREETYPE_CONFIG_SCRIPTS = freetype-config
HOST_FREETYPE_DEPENDENCIES = host-pkgconf
-HOST_FREETYPE_CONF_OPT = --without-png
+HOST_FREETYPE_CONF_OPT = --without-zlib --without-bzip2 --without-png
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+FREETYPE_DEPENDENCIES += zlib
+FREETYPE_CONF_OPT += --with-zlib
+else
+FREETYPE_CONF_OPT += --without-zlib
+endif
+
+ifeq ($(BR2_PACKAGE_BZIP2),y)
+FREETYPE_DEPENDENCIES += bzip2
+FREETYPE_CONF_OPT += --with-bzip2
+else
+FREETYPE_CONF_OPT += --without-bzip2
+endif
ifeq ($(BR2_PACKAGE_LIBPNG),y)
FREETYPE_DEPENDENCIES += libpng