summaryrefslogtreecommitdiff
path: root/package/gawk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-12-06 12:13:59 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-13 16:01:20 +0100
commit6f7ee942c6e4c0eb1aa2bc3ed487d8fcb1ce0085 (patch)
treeb9981dab1fe75ee4210794424284052565a8919f /package/gawk
parenta3fd70c0431a8905ff7840071373265d8fe28229 (diff)
package/gawk: add optional readline dependency
The gawk debugger can optionally use readline for user input during the debugging session (for the usual autocompletion and stuff). Enable readline support when the readline package is enabled; let ./configure automatically find it. Forcibly disable readline support when the readline package is disabled. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Peter Korsgaard <jacmet@uclibc.org> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gawk')
-rw-r--r--package/gawk/gawk.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/gawk/gawk.mk b/package/gawk/gawk.mk
index 0fd131d85..507ea6de6 100644
--- a/package/gawk/gawk.mk
+++ b/package/gawk/gawk.mk
@@ -24,6 +24,14 @@ else
GAWK_CONF_OPTS += --without-mpfr
endif
+# --with-readline requires an argument so just let
+# configure find it automatically
+ifeq ($(BR2_PACKAGE_READLINE),y)
+GAWK_DEPENDENCIES += readline
+else
+GAWK_CONF_OPTS += --without-readline
+endif
+
# We don't have a host-busybox, and we don't want to use readline or mpfr
HOST_GAWK_DEPENDENCIES =