summaryrefslogtreecommitdiff
path: root/package/gdb
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2017-01-22 20:17:09 +0100
committerPeter Korsgaard <peter@korsgaard.com>2017-01-23 23:07:39 +0100
commitba8338060bd10abb49a7ca413fd5ea53e80b0868 (patch)
treeb0aa51fb1c85f6811341b8f2f9246e90350752fd /package/gdb
parent5c9db62171cefb125193a6f814a0046536fc76a1 (diff)
gdb: unbreak 7.12 target gdb/gdbserver build without C++ support
gdb 7.12+ by default builds with a C++ compiler, which naturally doesn't work when we don't have C++ support in the toolchain. Fix it by passing --disable-build-with-cxx for such setups. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gdb')
-rw-r--r--package/gdb/gdb.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
index ea27d0c6e..606f1f960 100644
--- a/package/gdb/gdb.mk
+++ b/package/gdb/gdb.mk
@@ -107,6 +107,12 @@ ifeq ($(BR2_arc),y)
GDB_CONF_OPTS += --disable-build-with-cxx
endif
+# gdb 7.12+ by default builds with a C++ compiler, which doesn't work
+# when we don't have C++ support in the toolchain
+ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
+GDB_CONF_OPTS += --disable-build-with-cxx
+endif
+
ifeq ($(BR2_PACKAGE_GDB_TUI),y)
GDB_CONF_OPTS += --enable-tui
else