summaryrefslogtreecommitdiff
path: root/package/gettext
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-02-04 16:36:18 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-04 18:10:15 +0100
commit12d150727a8dff2d6a4c3013936c27fe71ce588d (patch)
treeb5c627479cfaa513b66a77431bb9185b007355cf /package/gettext
parentdcd0b3cc7b585835a9f4fb76264919946456dcaf (diff)
Strip *.so* and not only executable files
Our current stripping strategy requires that shared libraries have the executable permission. However, this is by far not something recognized as a standard behavior: Debian/Ubuntu distributions for example do not have executable permissions on their libraries. Therefore, pushing to upstream packages fixes that add the executable permissions is not easy. As a result, this commit improves the stripping logic so that it not only strips the files that are executable, but also the ones that match '*.so*', which should match both the shared libraries and the dlopen()'able plugins, as long as they have a .so extension. Thanks to this addition, a number of manual "chmod +x" done by various packages can be removed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gettext')
-rw-r--r--package/gettext/gettext.mk7
1 files changed, 0 insertions, 7 deletions
diff --git a/package/gettext/gettext.mk b/package/gettext/gettext.mk
index fbdb19ced..748c2a59f 100644
--- a/package/gettext/gettext.mk
+++ b/package/gettext/gettext.mk
@@ -57,12 +57,5 @@ endef
endif
endif # GETTEXT_TOOLS = n
-# Library lacks +x so strip skips it
-define GETTEXT_FIX_LIBRARY_MODE
- -chmod +x $(TARGET_DIR)/usr/lib/libintl.so*
-endef
-
-GETTEXT_POST_INSTALL_TARGET_HOOKS += GETTEXT_FIX_LIBRARY_MODE
-
$(eval $(autotools-package))
$(eval $(host-autotools-package))