summaryrefslogtreecommitdiff
path: root/package/gettext
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-06-28 23:52:23 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-07-01 14:58:26 +0200
commitd49b9f3d8befcd74aeb8c2c948320ff78c063ffe (patch)
tree53b48be330257d303016b2edb9fc42dc26589ebf /package/gettext
parent12b6eebe1295b9f63d5b67fd35efb77fa12dc886 (diff)
gettext: remove useless ABOUT-NLS file
For some reason, gettext installs on the target a documentation file named ABOUT-NLS in /usr/share/gettext, that is clearly not needed for the proper execution of programs. This commit adds a post-install hook in gettext.mk to get rid of this file. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gettext')
-rw-r--r--package/gettext/gettext.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/gettext/gettext.mk b/package/gettext/gettext.mk
index 948ab9de5..cc461f7e0 100644
--- a/package/gettext/gettext.mk
+++ b/package/gettext/gettext.mk
@@ -50,6 +50,13 @@ endef
GETTEXT_POST_PATCH_HOOKS += HOST_GETTEXT_DISABLE_UNNEEDED
HOST_GETTEXT_POST_PATCH_HOOKS += HOST_GETTEXT_DISABLE_UNNEEDED
+define GETTEXT_REMOVE_UNNEEDED
+ $(RM) -rf $(TARGET_DIR)/usr/share/gettext/ABOUT-NLS
+ rmdir --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share/gettext
+endef
+
+GETTEXT_POST_INSTALL_TARGET_HOOKS += GETTEXT_REMOVE_UNNEEDED
+
# Force build with NLS support, otherwise libintl is not built
# This is needed because some packages (eg. libglib2) requires
# locales, but do not properly depend on BR2_ENABLE_LOCALE, and