summaryrefslogtreecommitdiff
path: root/package/gflags
diff options
context:
space:
mode:
authorRahul Bedarkar <rahul.bedarkar@imgtec.com>2015-06-10 11:20:48 +0530
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-10 09:39:46 +0200
commit97b7fd055dcbdbf9064aff30641742d4f488e134 (patch)
treea287ae5c4a9b59c8a3e43e140e8b700e4e9dc7f2 /package/gflags
parent187997ebb9d9b800f7c8360b0015d18819e508f9 (diff)
gflags: new package
Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com> Reviewed-by: Abhimanyu Vishwakarma <abhimanyu.v@imgtec.com> Reviewed-by: Marcin Nowakowski <marcin.nowakowski@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gflags')
-rw-r--r--package/gflags/Config.in13
-rw-r--r--package/gflags/gflags.hash2
-rw-r--r--package/gflags/gflags.mk17
3 files changed, 32 insertions, 0 deletions
diff --git a/package/gflags/Config.in b/package/gflags/Config.in
new file mode 100644
index 000000000..ed059445b
--- /dev/null
+++ b/package/gflags/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_GFLAGS
+ bool "gflags"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ The gflags package contains a C++ library that implements
+ commandline flags processing. It includes built-in support for
+ standard types such as string and the ability to define flags
+ in the source file in which they are used.
+
+ https://github.com/gflags/gflags
+
+comment "gflags needs a toolchain w/ C++"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/gflags/gflags.hash b/package/gflags/gflags.hash
new file mode 100644
index 000000000..9c8b27a4b
--- /dev/null
+++ b/package/gflags/gflags.hash
@@ -0,0 +1,2 @@
+# No hash for v2.1.2, comes from the github-helper:
+none xxx gflags-v2.1.2.tar.gz
diff --git a/package/gflags/gflags.mk b/package/gflags/gflags.mk
new file mode 100644
index 000000000..661dad872
--- /dev/null
+++ b/package/gflags/gflags.mk
@@ -0,0 +1,17 @@
+################################################################################
+#
+# gflags
+#
+################################################################################
+
+GFLAGS_VERSION = v2.1.2
+GFLAGS_SITE = $(call github,gflags,gflags,$(GFLAGS_VERSION))
+GFLAGS_INSTALL_STAGING = YES
+GFLAGS_LICENSE = BSD-3c
+GFLAGS_LICENSE_FILES = COPYING.txt
+
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
+GFLAGS_CONF_OPTS = -DBUILD_gflags_LIB=OFF
+endif
+
+$(eval $(cmake-package))