summaryrefslogtreecommitdiff
path: root/package/git-crypt
diff options
context:
space:
mode:
authorFrancesco Negri <francesconegri@gmail.com>2017-01-30 14:55:17 +0100
committerPeter Korsgaard <peter@korsgaard.com>2017-01-30 15:38:04 +0100
commit8c43f5fd37e2cb4298c042b07b1ba017ebcd9256 (patch)
tree69ff4eb43884289ccfda948db0fdf34038a832a9 /package/git-crypt
parent4e43e7c53a8e17b218ef1b43f2036f9727871357 (diff)
git-crypt: new package
[Peter: git is a runtime dependency, use pkg-config for openssl dependencies, use make install] Signed-off-by: Francesco Negri <francesconegri@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/git-crypt')
-rw-r--r--package/git-crypt/Config.in15
-rw-r--r--package/git-crypt/git-crypt.hash2
-rw-r--r--package/git-crypt/git-crypt.mk25
3 files changed, 42 insertions, 0 deletions
diff --git a/package/git-crypt/Config.in b/package/git-crypt/Config.in
new file mode 100644
index 000000000..362fe9a60
--- /dev/null
+++ b/package/git-crypt/Config.in
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_GIT_CRYPT
+ bool "git-crypt"
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_USE_MMU # git
+ select BR2_PACKAGE_GIT # runtime
+ select BR2_PACKAGE_OPENSSL
+ help
+ git-crypt enables transparent encryption and decryption of
+ files in a git repository.
+
+ https://www.agwa.name/projects/git-crypt/
+
+comment "git-crypt needs a toolchain w/ C++"
+ depends on !BR2_INSTALL_LIBSTDCPP
+ depends on BR2_USE_MMU
diff --git a/package/git-crypt/git-crypt.hash b/package/git-crypt/git-crypt.hash
new file mode 100644
index 000000000..8589f03f7
--- /dev/null
+++ b/package/git-crypt/git-crypt.hash
@@ -0,0 +1,2 @@
+# Hash from: https://lists.cloudmutt.com/pipermail/git-crypt-announce/2015-May/000003.html
+sha256 0a8f92c0a0a125bf768d0c054d947ca4e4b8d6556454b0e7e87fb907ee17cf06 git-crypt-0.5.0.tar.gz
diff --git a/package/git-crypt/git-crypt.mk b/package/git-crypt/git-crypt.mk
new file mode 100644
index 000000000..7785ddcfd
--- /dev/null
+++ b/package/git-crypt/git-crypt.mk
@@ -0,0 +1,25 @@
+################################################################################
+#
+# git-crypt
+#
+################################################################################
+
+GIT_CRYPT_VERSION = 0.5.0
+GIT_CRYPT_SITE = https://www.agwa.name/projects/git-crypt/downloads
+GIT_CRYPT_DEPENDENCIES = host-pkgconf openssl
+GIT_CRYPT_LICENSE = GPLv3+, MIT
+GIT_CRYPT_LICENSE_FILES = COPYING parse_options.hpp
+
+GIT_CRYPT_LIBS = `$(PKG_CONFIG_HOST_BINARY) --libs openssl`
+
+define GIT_CRYPT_BUILD_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
+ LDFLAGS="$(TARGET_LDFLAGS) $(GIT_CRYPT_LIBS)" PREFIX=/usr
+endef
+
+define GIT_CRYPT_INSTALL_TARGET_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) \
+ PREFIX=/usr install
+endef
+
+$(eval $(generic-package))