summaryrefslogtreecommitdiff
path: root/package/glibc
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-10-26 23:47:58 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-10-27 10:40:15 +0200
commit2c877590b3b18df4853989a66378c184713ccd55 (patch)
treebe0072c6ae1c5a251e9375bdf71f51847fe5bef8 /package/glibc
parent652a8b3e907a0b73a57fbb028590f5c6139bc88c (diff)
glibc: install libmvec.so when available
On some architectures (namely x86-64), glibc may provide a libmvec library since glibc 2.22, which programs built with gcc OpenMP support might get linked to. In order for these programs to work on the target, we need to copy this library to the target filesystem. This commit takes care of this for the glibc package (used for the internal toolchain backend). Note that libraries listed in GLIBC_LIBS_LIB are silently ignored if they don't exist. Therefore, we don't need to have any condition on the architecture or glibc version. For more details on libmvec, see https://sourceware.org/glibc/wiki/libmvec. Fixes bug #9111. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/glibc')
-rw-r--r--package/glibc/glibc.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/glibc/glibc.mk b/package/glibc/glibc.mk
index 50154e851..c11f7cd86 100644
--- a/package/glibc/glibc.mk
+++ b/package/glibc/glibc.mk
@@ -103,7 +103,7 @@ endef
GLIBC_LIBS_LIB = \
ld*.so.* libc.so.* libcrypt.so.* libdl.so.* libgcc_s.so.* libm.so.* \
libnsl.so.* libpthread.so.* libresolv.so.* librt.so.* libutil.so.* \
- libnss_files.so.* libnss_dns.so.*
+ libnss_files.so.* libnss_dns.so.* libmvec.so.*
ifeq ($(BR2_PACKAGE_GDB),y)
GLIBC_LIBS_LIB += libthread_db.so.*