summaryrefslogtreecommitdiff
path: root/package/glm
diff options
context:
space:
mode:
authorPaul Cercueil <paul@crapouillou.net>2014-08-15 19:19:38 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-09-28 21:33:42 +0200
commit6f6a622240fb1ad567dfbe08fad5bfc0a749d5f7 (patch)
tree59dd9a29402925db088f8879ba84818883f7dcdd /package/glm
parent997c17a84c04cc4a63b15ff062d1ce8e5106cab4 (diff)
glm: Added package
OpenGL Mathematics (GLM) is a header only C++ mathematics library for graphics software based on the OpenGL Shading Language (GLSL) specification. http://glm.g-truc.net/ Signed-off-by: Paul Cercueil <paul@crapouillou.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/glm')
-rw-r--r--package/glm/Config.in10
-rw-r--r--package/glm/glm.mk17
2 files changed, 27 insertions, 0 deletions
diff --git a/package/glm/Config.in b/package/glm/Config.in
new file mode 100644
index 000000000..41b360837
--- /dev/null
+++ b/package/glm/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_GLM
+ bool "glm"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ OpenGL Mathematics (GLM)
+
+ http://glm.g-truc.net
+
+comment "glm needs a toolchain w/ C++"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/glm/glm.mk b/package/glm/glm.mk
new file mode 100644
index 000000000..ff9423da1
--- /dev/null
+++ b/package/glm/glm.mk
@@ -0,0 +1,17 @@
+################################################################################
+#
+# glm
+#
+################################################################################
+
+GLM_VERSION = 0.9.5.4
+GLM_SITE = $(call github,g-truc,glm,$(GLM_VERSION))
+GLM_LICENSE = MIT
+GLM_LICENSE_FILES = copying.txt
+
+# GLM is a header-only library, it only makes sense
+# to have it installed into the staging directory.
+GLM_INSTALL_STAGING = YES
+GLM_INSTALL_TARGET = NO
+
+$(eval $(cmake-package))