summaryrefslogtreecommitdiff
path: root/package/glog
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-02 16:31:33 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-06 11:16:00 +0100
commit8df95843ed1090b7be41b541bbcf111b86cb4c4d (patch)
tree6e73c2f19817d58f9a723b67d5753dfc18cbe425 /package/glog
parent4a3f597a0ea3392bbd1063c40291743955309472 (diff)
glog: fix atomic built-in problem
glog can optionally use atomic __sync built-ins. However, its configure script only checks for the availability of the 4-byte variant, but the code also uses the 1-byte variant. While this works on most architectures, it does not on architectures that implement only the 4-byte variant, such as Microblaze. So if the architecture does not implement the 1-byte variant, we hint the configure script that atomic built-ins should not be used. Fixes: http://autobuild.buildroot.org/results/bedebd594c283adf39374c9a9f44432e5d6cbff7/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'package/glog')
-rw-r--r--package/glog/glog.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/glog/glog.mk b/package/glog/glog.mk
index 8a8409487..aa7cacbdd 100644
--- a/package/glog/glog.mk
+++ b/package/glog/glog.mk
@@ -14,4 +14,15 @@ ifeq ($(BR2_PACKAGE_GFLAGS),y)
GLOG_DEPENDENCIES = gflags
endif
+# glog can optionally use atomic __sync built-ins. However, its
+# configure script only checks for the availability of the 4 bytes
+# version, but the code also uses the 1 byte version. While this works
+# on most architectures, it does not on architectures that implement
+# only the 4 bytes version, such as Microblaze. So if the architecture
+# does not implement the 1 byte version, we hint the configure script
+# that atomic built-ins should not be used.
+ifeq ($(BR2_TOOLCHAIN_HAS_SYNC_1),)
+GLOG_CONF_ENV += ac_cv___sync_val_compare_and_swap=no
+endif
+
$(eval $(autotools-package))