summaryrefslogtreecommitdiff
path: root/package/gnupg2
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@openwide.fr>2014-09-23 23:57:37 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-01 22:45:24 +0200
commit5f9d235e667b5ae61e90b1c03efdf2055e62c262 (patch)
tree6ec43401aa7a7bf75eee673e22f87db7874e2231 /package/gnupg2
parentb39e3e39eb15264efafec3cb7c4ac89a951b9ab9 (diff)
package/gnupg2: add readline optional dependency
This is to improve build reproducibility. [Thomas: add --with-readline and --without-readline options to explicitly enable/disable readline usage.] Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gnupg2')
-rw-r--r--package/gnupg2/gnupg2.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/gnupg2/gnupg2.mk b/package/gnupg2/gnupg2.mk
index b0e72976b..4b0a26e25 100644
--- a/package/gnupg2/gnupg2.mk
+++ b/package/gnupg2/gnupg2.mk
@@ -33,4 +33,11 @@ else
GNUPG2_CONF_OPT += --disable-bzip2
endif
+ifeq ($(BR2_PACKAGE_READLINE),y)
+GNUPG2_CONF_OPT += --with-readline=$(STAGING_DIR)
+GNUPG2_DEPENDENCIES += readline
+else
+GNUPG2_CONF_OPT += --without-readline
+endif
+
$(eval $(autotools-package))