summaryrefslogtreecommitdiff
path: root/package/gnupg
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-07-02 17:30:24 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-07-02 17:30:24 +0200
commita6a2962d998c82f888957fb19bd2933bbf73f92d (patch)
tree061e62ba2029a51bf51104c1b0d8e4ec9ba72168 /package/gnupg
parent7f1def693647b2158aab38d86a11609454e72dab (diff)
gnupg: add option for AES cipher
Similar to our RSA option. Enabling this adds ~17K to the gpg binary (ARMv7): ls -lah output/target/usr/bin/gpg{.orig,} -rwxr-xr-x 1 peko peko 532K Jul 2 17:29 output/target/usr/bin/gpg -rwxr-xr-x 1 peko peko 515K Jul 2 17:29 output/target/usr/bin/gpg.orig Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gnupg')
-rw-r--r--package/gnupg/Config.in5
-rw-r--r--package/gnupg/gnupg.mk6
2 files changed, 11 insertions, 0 deletions
diff --git a/package/gnupg/Config.in b/package/gnupg/Config.in
index 1dc27a47c..30f215fed 100644
--- a/package/gnupg/Config.in
+++ b/package/gnupg/Config.in
@@ -16,6 +16,11 @@ config BR2_PACKAGE_GNUPG
if BR2_PACKAGE_GNUPG
+config BR2_PACKAGE_GNUPG_AES
+ bool "AES support"
+ help
+ Support for the AES cipher
+
config BR2_PACKAGE_GNUPG_RSA
bool "RSA support"
help
diff --git a/package/gnupg/gnupg.mk b/package/gnupg/gnupg.mk
index 94f5d896a..f358fa36f 100644
--- a/package/gnupg/gnupg.mk
+++ b/package/gnupg/gnupg.mk
@@ -31,6 +31,12 @@ else
GNUPG_CONF_OPTS += --without-readline
endif
+ifeq ($(BR2_PACKAGE_GNUPG_AES),y)
+GNUPG_CONF_OPTS += --enable-aes
+else
+GNUPG_CONF_OPTS += --disable-aes
+endif
+
ifeq ($(BR2_PACKAGE_GNUPG_RSA),y)
GNUPG_CONF_OPTS += --enable-rsa
else