summaryrefslogtreecommitdiff
path: root/package/gnuradio
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2016-10-16 13:12:41 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-10-22 16:21:14 +0200
commit1255d0080ccecebfa4d53dfd36d0cbde8a3c6e61 (patch)
treecd15d22f76ef4a198926ddc9208ce4c08dd592e7 /package/gnuradio
parentb353ce1315270e228d8c24f209f2037eec41b601 (diff)
package/gnuradio: include TARGET_CFLAGS to the overloaded CFLAGS
Signed-off-by: Samuel Martin <s.martin49@gmail.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gnuradio')
-rw-r--r--package/gnuradio/gnuradio.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/gnuradio/gnuradio.mk b/package/gnuradio/gnuradio.mk
index 972f7a494..5cb00d241 100644
--- a/package/gnuradio/gnuradio.mk
+++ b/package/gnuradio/gnuradio.mk
@@ -36,7 +36,7 @@ GNURADIO_INSTALL_STAGING = YES
# CFLAGS to decide whether to build the NEON functions or not, and
# wants to see the string 'armv7' in the CFLAGS.
ifeq ($(BR2_ARM_CPU_ARMV7A)$(BR2_ARM_CPU_HAS_NEON),yy)
-GNURADIO_CONF_OPTS += -DCMAKE_C_FLAGS="-march=armv7-a"
+GNURADIO_CONF_OPTS += -DCMAKE_C_FLAGS="$(TARGET_CFLAGS) -march=armv7-a"
endif
# As soon as -mfpu=neon is supported by the compiler, gnuradio will try