summaryrefslogtreecommitdiff
path: root/package/gnuradio
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-21 18:34:50 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-23 22:20:25 +0100
commit55163723ea14d4e5da75910e4bbb4af4aa7f1afe (patch)
treec85bd4cf525cc0aad04c48433d7580701611dff3 /package/gnuradio
parentf4f529975b9379f78d2053e002cd4253cc552989 (diff)
package/gnuradio: add optional support for orc
When orc was compiled before, gnuradio will use it as optional dependency: $ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/gnuradio-config-info | grep NEEDED [...] 0x0000000000000001 (NEEDED) Shared library: [liborc-0.4.so.0] [...] Apparently there is no option provided by the build system to en-/disable support for orc: https://github.com/gnuradio/volk/blob/41b4df055b2c8d4f2c23ad2bdc60c0b47b4f0dd8/lib/CMakeLists.txt#L449 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Reviewed-by: "Gwenhael Goavec-Merou" <gwenhael.goavec-merou@trabucayre.com> Tested-by: "Gwenhael Goavec-Merou" <gwenhael.goavec-merou@trabucayre.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gnuradio')
-rw-r--r--package/gnuradio/gnuradio.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/gnuradio/gnuradio.mk b/package/gnuradio/gnuradio.mk
index fc5cd1fa5..b7dbcb9fd 100644
--- a/package/gnuradio/gnuradio.mk
+++ b/package/gnuradio/gnuradio.mk
@@ -17,6 +17,10 @@ GNURADIO_DEPENDENCIES = \
host-swig \
boost
+ifeq ($(BR2_PACKAGE_ORC),y)
+GNURADIO_DEPENDENCIES += orc
+endif
+
GNURADIO_CONF_OPTS = \
-DENABLE_DEFAULT=OFF \
-DENABLE_VOLK=ON \