summaryrefslogtreecommitdiff
path: root/package/gnutls
diff options
context:
space:
mode:
authorAntoine Pierlot-Garcin <antoine@bokbox.com>2014-02-04 15:57:43 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-04 18:09:14 +0100
commitdcd0b3cc7b585835a9f4fb76264919946456dcaf (patch)
treef5ed8bddef0725b40021d8b6b2bd9c1c1c5f7c1f /package/gnutls
parent92f551abecd2323d992145973b1dbde85aa030c9 (diff)
gnutls: fix libz autodetection failure
The configure script finds libz in the distribution libraries, which causes zlib support to be dropped from the cross-compiled GnuTLS. Signed-off-by: Antoine Pierlot-Garcin <antoine@bokbox.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gnutls')
-rw-r--r--package/gnutls/gnutls.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
index 73b525d70..c0bd77826 100644
--- a/package/gnutls/gnutls.mk
+++ b/package/gnutls/gnutls.mk
@@ -28,8 +28,9 @@ GNUTLS_CONF_ENV = gl_cv_socket_ipv6=$(if $(BR2_INET_IPV6),yes,no) \
gl_cv_func_gettimeofday_clobber=no
GNUTLS_INSTALL_STAGING = YES
-# libpthread autodetection poisons the linkpath
+# libpthread and libz autodetection poison the linkpath
GNUTLS_CONF_OPT += $(if $(BR2_TOOLCHAIN_HAS_THREADS),--with-libpthread-prefix=$(STAGING_DIR)/usr)
+GNUTLS_CONF_OPT += $(if $(BR2_PACKAGE_ZLIB),--with-libz-prefix=$(STAGING_DIR)/usr)
# gnutls needs libregex, but pcre can be used too
# The check isn't cross-compile friendly