summaryrefslogtreecommitdiff
path: root/package/gnutls
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2015-12-04 14:01:39 -0300
committerPeter Korsgaard <peter@korsgaard.com>2015-12-04 21:38:03 +0100
commite6e90c7017b39418da24bfa2177444b0f9d4596d (patch)
treef914f2147d39669986302b4fc23b544425d0c8be /package/gnutls
parenta3e53aca96153f74f0718818b5a270e8f889d23f (diff)
gnutls: needs argp-standalone for musl/uclibc
It's required for crywrap (tools), fixes: http://autobuild.buildroot.net/results/2d9/2d98fced7ff7c3b5c39a97eb1c8db7dd651fa86c/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gnutls')
-rw-r--r--package/gnutls/Config.in2
-rw-r--r--package/gnutls/gnutls.mk6
2 files changed, 8 insertions, 0 deletions
diff --git a/package/gnutls/Config.in b/package/gnutls/Config.in
index dde23cec7..998e213c7 100644
--- a/package/gnutls/Config.in
+++ b/package/gnutls/Config.in
@@ -14,6 +14,8 @@ if BR2_PACKAGE_GNUTLS
config BR2_PACKAGE_GNUTLS_TOOLS
bool "install tools"
+ select BR2_PACKAGE_ARGP_STANDALONE \
+ if BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_MUSL
help
Install GnuTLS command line tools for various cryptographic tasks.
diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
index 3b9fc7fca..a7342d604 100644
--- a/package/gnutls/gnutls.mk
+++ b/package/gnutls/gnutls.mk
@@ -44,6 +44,12 @@ ifeq ($(BR2_PACKAGE_GNUTLS_TOOLS),)
GNUTLS_CONF_OPTS += --disable-crywrap
endif
+# Prerequisite for crywrap
+ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
+GNUTLS_CONF_ENV += LIBS="-largp"
+GNUTLS_DEPENDENCIES += argp-standalone
+endif
+
# libidn support for nommu must exclude the crywrap wrapper (uses fork)
GNUTLS_CONF_OPTS += $(if $(BR2_USE_MMU),,--disable-crywrap)