summaryrefslogtreecommitdiff
path: root/package/go-bootstrap
diff options
context:
space:
mode:
authorGeoff Levand <geoff@infradead.org>2016-05-12 00:08:46 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-12 16:06:57 +0200
commitdef633c4c5b339d13ef221cfa5c202aaf9989f91 (patch)
tree8c9d8822fb3f2c436472371f6457e95c7f779a97 /package/go-bootstrap
parent781ce19d746efb6a5408b4d50b30626784eff324 (diff)
package/go-bootstrap: Add toolchain dependency
To build programs that need cgo support the toolchain needs to be available. Cc: Christian Stewart <christian@paral.in> Signed-off-by: Geoff Levand <geoff@infradead.org> [Thomas: add comment in the code about the toolchain dependency.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/go-bootstrap')
-rw-r--r--package/go-bootstrap/go-bootstrap.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/go-bootstrap/go-bootstrap.mk b/package/go-bootstrap/go-bootstrap.mk
index e404cb696..fd2362894 100644
--- a/package/go-bootstrap/go-bootstrap.mk
+++ b/package/go-bootstrap/go-bootstrap.mk
@@ -11,6 +11,12 @@ GO_BOOTSTRAP_SOURCE = go$(GO_BOOTSTRAP_VERSION).src.tar.gz
GO_BOOTSTRAP_LICENSE = BSD-3c
GO_BOOTSTRAP_LICENSE_FILES = LICENSE
+# To build programs that need cgo support the toolchain needs to be
+# available, so the toolchain is not needed to build host-go-bootstrap
+# itself, but needed by other packages that depend on
+# host-go-bootstrap.
+HOST_GO_BOOTSTRAP_DEPENDENCIES = toolchain
+
HOST_GO_BOOTSTRAP_ROOT = $(HOST_DIR)/usr/lib/go-$(GO_BOOTSTRAP_VERSION)
HOST_GO_BOOTSTRAP_MAKE_ENV = \