summaryrefslogtreecommitdiff
path: root/package/gpsd
diff options
context:
space:
mode:
authorJames Knight <james.knight@rockwellcollins.com>2015-11-05 13:41:53 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-11-05 22:16:03 +0100
commit0524136e3d14a7d61c002606752b55b414b73447 (patch)
tree2b6909a27b58e8f426566c164837c93d9a01fbbd /package/gpsd
parente125bab6a3a23214e8aafb226249d7cb9a6a1455 (diff)
gpsd: adjust udev rules file permissions
Adjust a generated udev rule file (25-gpsd.rules) to have user write permissions. This is to prevent rebuild issues when the gpsd package fails to re-install on a target (since the `cp` of the rule file will fail due to permissions). [Thomas: minor tweaks to code comments and commit title.] Signed-off-by: James Knight <james.knight@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gpsd')
-rw-r--r--package/gpsd/gpsd.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/gpsd/gpsd.mk b/package/gpsd/gpsd.mk
index 577b43cfc..87911c390 100644
--- a/package/gpsd/gpsd.mk
+++ b/package/gpsd/gpsd.mk
@@ -217,6 +217,8 @@ define GPSD_INSTALL_STAGING_CMDS
install)
endef
+# After installing the udev rule, make it writable so that this
+# package can be re-built/re-installed.
ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
define GPSD_INSTALL_UDEV_RULES
(cd $(@D); \
@@ -225,6 +227,7 @@ define GPSD_INSTALL_UDEV_RULES
$(SCONS) \
$(GPSD_SCONS_OPTS) \
udev-install)
+ chmod u+w $(TARGET_DIR)/lib/udev/rules.d/25-gpsd.rules
endef
GPSD_POST_INSTALL_TARGET_HOOKS += GPSD_INSTALL_UDEV_RULES