summaryrefslogtreecommitdiff
path: root/package/gpsd
diff options
context:
space:
mode:
authorJames Knight <james.knight@rockwellcollins.com>2015-11-27 11:25:57 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-11-28 15:09:37 +0100
commit2cfc966f431c7c715b3fc11ca0467d47432fca33 (patch)
treebc3418772667b4ae707ff753694cae228a34ac7b /package/gpsd
parenta2d454a959b4b783010c59bf83a0e6ed479a17a5 (diff)
gpsd: enable kpps support
GPSD has the ability to support KPPS. Its enablement is determined primarily from the existence of `sys/timepps.h`. This file is provided from the pps-tools package. Adjusting GPSD's Makefile to depend on the pps-tools package if a developer has included pps-tools as part of a build. Signed-off-by: James Knight <james.knight@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gpsd')
-rw-r--r--package/gpsd/gpsd.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/gpsd/gpsd.mk b/package/gpsd/gpsd.mk
index 87911c390..30554034b 100644
--- a/package/gpsd/gpsd.mk
+++ b/package/gpsd/gpsd.mk
@@ -59,6 +59,12 @@ else
GPSD_SCONS_OPTS += bluez=no
endif
+# If pps-tools is available, build it before so the package can use it
+# (HAVE_SYS_TIMEPPS_H).
+ifeq ($(BR2_PACKAGE_PPS_TOOLS),y)
+GPSD_DEPENDENCIES += pps-tools
+endif
+
ifeq ($(BR2_PACKAGE_DBUS_GLIB),y)
GPSD_SCONS_OPTS += dbus_export=yes
GPSD_DEPENDENCIES += dbus-glib