summaryrefslogtreecommitdiff
path: root/package/gstreamer1/gstreamer1/gstreamer1.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2016-02-02 09:07:24 +0100
committerPeter Korsgaard <peter@korsgaard.com>2016-02-02 09:17:38 +0100
commitc15f70488b4b5fd132ccf27cc6ab556ba410e387 (patch)
tree95306d6984f788f291f0eaa9d946364c78cee09d /package/gstreamer1/gstreamer1/gstreamer1.mk
parent6709fad224692ae5e0788bbd30145f7d622b52a4 (diff)
gstreamer1: don't rely on a recent coreutils for relative symlink support
Fixes: http://autobuild.buildroot.net/results/3ae/3ae368cfd0ecd7be4c7e864590ec5dbf79d576ac/ http://autobuild.buildroot.net/results/4c9/4c951f31984e0eff21fc165cb68065f527c237e6/ And many more. The recent change to create the legacy gstconfig.h symlink using ln -srf unfortunately breaks on older distributions as it was only added in coreutils 8.16 (2012). Instead, "manually" create the relative symlink. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gstreamer1/gstreamer1/gstreamer1.mk')
-rw-r--r--package/gstreamer1/gstreamer1/gstreamer1.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/gstreamer1/gstreamer1/gstreamer1.mk b/package/gstreamer1/gstreamer1/gstreamer1.mk
index 0eb46e8a1..b78816012 100644
--- a/package/gstreamer1/gstreamer1/gstreamer1.mk
+++ b/package/gstreamer1/gstreamer1/gstreamer1.mk
@@ -41,8 +41,8 @@ GSTREAMER1_DEPENDENCIES = libglib2 host-pkgconf host-bison host-flex
# updated to look in the correct location.
# Add a symlink to the legacy location
define GSTREAMER1_LEGACY_CGSTCONFIG_H
- ln -srf $(STAGING_DIR)/usr/lib/gstreamer-1.0/include/gst/gstconfig.h \
- $(STAGING_DIR)/usr/include/gstreamer-1.0/gst/gstconfig.h
+ cd $(STAGING_DIR)/usr/include/gstreamer-1.0/gst && \
+ ln -sf ../../../lib/gstreamer-1.0/include/gst/gstconfig.h .
endef
GSTREAMER1_POST_INSTALL_STAGING_HOOKS += GSTREAMER1_LEGACY_CGSTCONFIG_H