summaryrefslogtreecommitdiff
path: root/package/gstreamer
diff options
context:
space:
mode:
authorAndrew Webster <awebster@arcx.com>2016-06-10 14:13:05 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-06-15 22:48:40 +0200
commit47e6203f63544345dffa4bdbad303b6045c4b11f (patch)
tree7f5ffe95191fdadbf98b6ce9b159c9db1b9d280e /package/gstreamer
parent77cb513912e2f02eb9fc4b2c9394ff03b1674b66 (diff)
imx-codec: rename from libfslcodec and bump version to 4.0.9
Changelog: --[aac_dec] refine the code for pure c build aac decoder c build need float point support, which use some float point function. This patch is based on the Yocto equivalent: https://github.com/Freescale/meta-fsl-arm/commit/4b91194 Implicitly tested through gstreamer as the 0.10 plugin relies on it: # gst-launch-0.10 playbin uri=file:///root/tears_of_steel_1080p.webm Signed-off-by: Andrew Webster <awebster@arcx.com> Reviewed-by: Gary Bisson <gary.bisson@boundarydevices.com> Tested-by: Gary Bisson <gary.bisson@boundarydevices.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gstreamer')
-rw-r--r--package/gstreamer/gst-fsl-plugins/Config.in4
-rw-r--r--package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/gstreamer/gst-fsl-plugins/Config.in b/package/gstreamer/gst-fsl-plugins/Config.in
index 0407dc525..8c82a4a02 100644
--- a/package/gstreamer/gst-fsl-plugins/Config.in
+++ b/package/gstreamer/gst-fsl-plugins/Config.in
@@ -9,12 +9,12 @@ config BR2_PACKAGE_GST_FSL_PLUGINS
bool "gst-fsl-plugins"
depends on BR2_LINUX_KERNEL
depends on BR2_arm # Only relevant for i.MX
- depends on BR2_TOOLCHAIN_USES_GLIBC # libfslcodec
+ depends on BR2_TOOLCHAIN_USES_GLIBC # imx-codec
select BR2_PACKAGE_GST_PLUGINS_BASE
select BR2_PACKAGE_LIBFSLVPUWRAP if BR2_PACKAGE_FREESCALE_IMX_HAS_VPU
select BR2_PACKAGE_IMX_LIB
select BR2_PACKAGE_LIBFSLPARSER
- select BR2_PACKAGE_LIBFSLCODEC
+ select BR2_PACKAGE_IMX_CODEC
select BR2_PACKAGE_FREESCALE_IMX
help
GStreamer plugins for hardware-accelerated audio and video
diff --git a/package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk b/package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk
index fa0e093a9..50732bffe 100644
--- a/package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk
+++ b/package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk
@@ -16,7 +16,7 @@ GST_FSL_PLUGINS_INSTALL_STAGING = YES
GST_FSL_PLUGINS_AUTORECONF = YES
GST_FSL_PLUGINS_DEPENDENCIES += host-pkgconf gstreamer gst-plugins-base \
- imx-lib libfslparser libfslcodec
+ imx-lib libfslparser imx-codec
ifeq ($(BR2_PACKAGE_FREESCALE_IMX_HAS_VPU),y)
GST_FSL_PLUGINS_DEPENDENCIES += libfslvpuwrap