summaryrefslogtreecommitdiff
path: root/package/gtest
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2016-08-31 18:29:54 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-09-06 22:55:53 +0200
commit0cd962b3bcb842985369cb276e6cba0f8b15289c (patch)
tree4a6c3826af00ec44bc05b64c2899f4868a5389af /package/gtest
parentfc8cac962baf5668dbc623ae5d411b75f77d3384 (diff)
gtest: retrieve package from github
https://googletest.googlecode.com/files is no more available, so update gtest.mk and gtest.hash to retrieve googletest source code as a tar.gz (and not a zip) from github as https://googletest.googlecode.com is now a redirection to https://github.com/google/googletest. Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gtest')
-rw-r--r--package/gtest/gtest.hash4
-rw-r--r--package/gtest/gtest.mk9
2 files changed, 4 insertions, 9 deletions
diff --git a/package/gtest/gtest.hash b/package/gtest/gtest.hash
index 8ff79cb0d..79e31e466 100644
--- a/package/gtest/gtest.hash
+++ b/package/gtest/gtest.hash
@@ -1,2 +1,2 @@
-# From http://code.google.com/p/googletest/downloads/detail?name=gtest-1.7.0.zip&can=2&q=
-sha1 f85f6d2481e2c6c4a18539e391aa4ea8ab0394af gtest-1.7.0.zip
+# Locally computed:
+sha256 f73a6546fdf9fce9ff93a5015e0333a8af3062a152a9ad6bcb772c96687016cc gtest-release-1.7.0.tar.gz
diff --git a/package/gtest/gtest.mk b/package/gtest/gtest.mk
index 11aa7e9ba..eb30905c2 100644
--- a/package/gtest/gtest.mk
+++ b/package/gtest/gtest.mk
@@ -5,9 +5,8 @@
################################################################################
# Make sure this remains the same version as the gmock one
-GTEST_VERSION = 1.7.0
-GTEST_SOURCE = gtest-$(GTEST_VERSION).zip
-GTEST_SITE = http://googletest.googlecode.com/files
+GTEST_VERSION = release-1.7.0
+GTEST_SITE = $(call github,google,googletest,$(GTEST_VERSION))
GTEST_INSTALL_STAGING = YES
GTEST_INSTALL_TARGET = NO
GTEST_LICENSE = BSD-3c
@@ -22,10 +21,6 @@ GTEST_LICENSE_FILES = LICENSE
# the gtest sources.
GTEST_CONF_OPTS = -DBUILD_SHARED_LIBS=OFF
-define GTEST_EXTRACT_CMDS
- $(UNZIP) $(DL_DIR)/$(GTEST_SOURCE) -d $(BUILD_DIR)
-endef
-
define GTEST_INSTALL_STAGING_CMDS
$(INSTALL) -D -m 0755 $(@D)/libgtest.a $(STAGING_DIR)/usr/lib/libgtest.a
$(INSTALL) -D -m 0755 $(@D)/libgtest_main.a $(STAGING_DIR)/usr/lib/libgtest_main.a