summaryrefslogtreecommitdiff
path: root/package/gtest
diff options
context:
space:
mode:
authorErico Nunes <erico.nunes@datacom.ind.br>2015-01-20 16:54:33 -0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-25 18:45:20 +0100
commit5f846793386e1924c38b8926b0f74ee510001f97 (patch)
tree9be63da8e18023f4facc97902f2b022dcba7f7a9 /package/gtest
parentbf0777802a00fb893957537aa0205f1570bc2b8b (diff)
gtest: install libgtest_main to staging
gtest provides a separate libgtest_main library with a default main() implementation for tests with basic needs. This separate library isn't being installed by buildroot. This patch adds the installation of this library to staging during the install of gtest. Signed-off-by: Erico Nunes <erico.nunes@datacom.ind.br> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gtest')
-rw-r--r--package/gtest/gtest.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/gtest/gtest.mk b/package/gtest/gtest.mk
index 3f3e8896d..7129c939d 100644
--- a/package/gtest/gtest.mk
+++ b/package/gtest/gtest.mk
@@ -27,6 +27,7 @@ endef
define GTEST_INSTALL_STAGING_CMDS
$(INSTALL) -D -m 0755 $(@D)/libgtest.a $(STAGING_DIR)/usr/lib/libgtest.a
+ $(INSTALL) -D -m 0755 $(@D)/libgtest_main.a $(STAGING_DIR)/usr/lib/libgtest_main.a
$(INSTALL) -d -m 0755 $(STAGING_DIR)/usr/include/gtest/
cp -rp $(@D)/include/gtest/* $(STAGING_DIR)/usr/include/gtest/
endef