summaryrefslogtreecommitdiff
path: root/package/gtest
diff options
context:
space:
mode:
authorCarlos Santos <casantos@datacom.ind.br>2015-07-31 08:53:42 -0300
committerPeter Korsgaard <peter@korsgaard.com>2015-10-03 17:11:01 +0200
commit63086aa42f28c806663ab9df15c94083f2a8bb1f (patch)
tree8efd695416948a0ccca1abb4b12e614dc3e9f0c3 /package/gtest
parentd6d1848c89afd0001b5419f5f1e8983c6cf83b91 (diff)
gmock: new package
Inspired by jMock, EasyMock, and Hamcrest, and designed with C++'s specifics in mind, Google C++ Mocking Framework (or Google Mock for short) is a library for writing and using C++ mock classes. Google Mock: * lets you create mock classes trivially using simple macros, * supports a rich set of matchers and actions, * handles unordered, partially ordered, or completely ordered expectations, * is extensible by users, and * works on Linux, Mac OS X, Windows, Windows Mobile, minGW, and Symbian. http://code.google.com/p/googlemock/ There are both host and target packages. The target one has include files required to compile the tests and the static libraries required to link/run them. The host package installs gmock_gen, a Python script used to generate code mocks. Notice that GMock 1.7.0 requires the Python 2 host package even if Python 3 is selected as a target package. Signed-off-by: Marcelo Barbosa <marcelo.barbosa@datacom.ind.br> Signed-off-by: Carlos Santos <casantos@datacom.ind.br> Reviewed-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gtest')
-rw-r--r--package/gtest/gtest.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/gtest/gtest.mk b/package/gtest/gtest.mk
index 562acf015..da0862102 100644
--- a/package/gtest/gtest.mk
+++ b/package/gtest/gtest.mk
@@ -4,6 +4,7 @@
#
################################################################################
+# Make sure this remains the same version as the gmock one
GTEST_VERSION = 1.7.0
GTEST_SOURCE = gtest-$(GTEST_VERSION).zip
GTEST_SITE = http://googletest.googlecode.com/files