summaryrefslogtreecommitdiff
path: root/package/gupnp-tools
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2016-07-29 09:51:29 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-30 16:12:36 +0200
commit6008f02fc82c3cfcb4bb6e8e6e99e5dd7396b500 (patch)
treee11a906b42d9d42fa2db593256c1ea5dd38731ee /package/gupnp-tools
parentb8a52bceaed96d969b5717f9afb1bd05b34bfd59 (diff)
gupnp-tools: new package
GUPnP Tools are free replacements of Intel UPnP tools that use GUPnP. They provides client and server side tools which enable one to easily test and debug one's UPnP devices and control points. http://www.gupnp.org/ Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com> [Thomas: - use "depends on BR2_PACKAGE_LIBGTK3" instead of a select, and simplify the Config.in comments consequently. - move from "Development tools" to "Networking applications" - license is GPLv2+, not LGPLv2+.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gupnp-tools')
-rw-r--r--package/gupnp-tools/Config.in21
-rw-r--r--package/gupnp-tools/gupnp-tools.hash2
-rw-r--r--package/gupnp-tools/gupnp-tools.mk35
3 files changed, 58 insertions, 0 deletions
diff --git a/package/gupnp-tools/Config.in b/package/gupnp-tools/Config.in
new file mode 100644
index 000000000..f9e645a09
--- /dev/null
+++ b/package/gupnp-tools/Config.in
@@ -0,0 +1,21 @@
+config BR2_PACKAGE_GUPNP_TOOLS
+ bool "gupnp-tools"
+ # gssdp, gupnp, libsoup all select on libglib2, so they have
+ # the same dependencies as libgtk3, which we depend on. So for
+ # the same of simplicity, we don't replicate all those
+ # (complex) dependencies.
+ select BR2_PACKAGE_GSSDP
+ select BR2_PACKAGE_GUPNP
+ select BR2_PACKAGE_LIBSOUP
+ select BR2_PACKAGE_LIBXML2
+ depends on BR2_PACKAGE_LIBGTK3
+ help
+ GUPnP Tools are free replacements of Intel UPnP tools that
+ use GUPnP. They provides client and server side tools which
+ enable one to easily test and debug one's UPnP devices and
+ control points.
+
+ http://www.gupnp.org/
+
+comment "gupnp-tools needs libgtk3"
+ depends on !BR2_PACKAGE_LIBGTK3
diff --git a/package/gupnp-tools/gupnp-tools.hash b/package/gupnp-tools/gupnp-tools.hash
new file mode 100644
index 000000000..0d37a8772
--- /dev/null
+++ b/package/gupnp-tools/gupnp-tools.hash
@@ -0,0 +1,2 @@
+# Hash from: http://ftp.gnome.org/pub/gnome/sources/gupnp-tools/0.8/gupnp-tools-0.8.12.sha256sum:
+sha256 658de96953608c4b1f47578ae563a7066d1f1983565daf22ad52b7b328ef97b1 gupnp-tools-0.8.12.tar.xz
diff --git a/package/gupnp-tools/gupnp-tools.mk b/package/gupnp-tools/gupnp-tools.mk
new file mode 100644
index 000000000..75920db09
--- /dev/null
+++ b/package/gupnp-tools/gupnp-tools.mk
@@ -0,0 +1,35 @@
+################################################################################
+#
+# gupnp-tools
+#
+################################################################################
+
+GUPNP_TOOLS_VERSION_MAJOR = 0.8
+GUPNP_TOOLS_VERSION = $(GUPNP_TOOLS_VERSION_MAJOR).12
+GUPNP_TOOLS_SOURCE = gupnp-tools-$(GUPNP_TOOLS_VERSION).tar.xz
+GUPNP_TOOLS_SITE = \
+ http://ftp.gnome.org/pub/gnome/sources/gupnp-tools/$(GUPNP_TOOLS_VERSION_MAJOR)
+GUPNP_TOOLS_LICENSE = GPLv2+
+GUPNP_TOOLS_LICENSE_FILES = COPYING
+GUPNP_TOOLS_INSTALL_STAGING = YES
+GUPNP_TOOLS_DEPENDENCIES = \
+ host-pkgconf \
+ libglib2 \
+ libxml2 \
+ gssdp \
+ gupnp \
+ libsoup \
+ libgtk3
+
+ifeq ($(BR2_PACKAGE_GUPNP_AV),y)
+GUPNP_TOOLS_CONF_OPTS += --with-av
+GUPNP_TOOLS_DEPENDENCIES += gupnp-av
+else
+GUPNP_TOOLS_CONF_OPTS += --without-av
+endif
+
+ifeq ($(BR2_PACKAGE_GTKSOURCEVIEW),y)
+GUPNP_TOOLS_DEPENDENCIES += gtksourceview
+endif
+
+$(eval $(autotools-package))