summaryrefslogtreecommitdiff
path: root/package/hostapd
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-03-04 10:35:11 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-03-04 19:34:15 +0100
commit30a8b49576437555ef98e632121dc52d0969c077 (patch)
treeaf2f06d2f6d88ca83751bdca007ff35c816c6ec1 /package/hostapd
parentd5604d9c3de6cd0b24db1351227b017fd8a8be75 (diff)
hostapd: fix static linking
A rebase of Samuel Martin's http://patchwork.ozlabs.org/patch/312320/ hostapd doesn't use pkg-config and upstream likely wouldn't take a patch to do so (hostapd/wpa_supplicant are used in android builds, and it doesn't use any auto* stuff either) so pass it in LIBS since we always build openssl with libz support. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/hostapd')
-rw-r--r--package/hostapd/hostapd.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/hostapd/hostapd.mk b/package/hostapd/hostapd.mk
index 37de60d95..5b7dd7748 100644
--- a/package/hostapd/hostapd.mk
+++ b/package/hostapd/hostapd.mk
@@ -43,6 +43,7 @@ endif
# Try to use openssl if it's already available
ifeq ($(BR2_PACKAGE_OPENSSL),y)
HOSTAPD_DEPENDENCIES += openssl
+ HOSTAPD_LIBS += $(if $(BR2_PREFER_STATIC_LIB),-lcrypto -lz)
HOSTAPD_CONFIG_EDITS += 's/\#\(CONFIG_TLS=openssl\)/\1/'
else
HOSTAPD_CONFIG_DISABLE += CONFIG_EAP_PWD