summaryrefslogtreecommitdiff
path: root/package/httping
diff options
context:
space:
mode:
authorYuvaraj Patil <yuvaraj.patil@wipro.com>2014-07-23 17:17:22 +0530
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-29 20:43:09 +0200
commit8793ddcd6f87b50934a4b4d1a53b7bf54cf650cb (patch)
tree11a30cea876afc4bc0177c653790bfb58bfdf2da /package/httping
parentffc9e4680c1634fd7f2e088889c9ffbd43f4968c (diff)
httping: fix math library linking
Add the math library directive '-lm' to linker options at the end. The order of the math library directive '-lm' matters. Fixes: http://autobuild.buildroot.net/results/843/84382290696e72c23995f5ed020ad5c157817012/ Signed-off-by: Yuvaraj Patil <yuvaraj.patil@wipro.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/httping')
-rw-r--r--package/httping/httping-0001-fix-math-library-linking.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/httping/httping-0001-fix-math-library-linking.patch b/package/httping/httping-0001-fix-math-library-linking.patch
new file mode 100644
index 000000000..0078f41c6
--- /dev/null
+++ b/package/httping/httping-0001-fix-math-library-linking.patch
@@ -0,0 +1,25 @@
+Move LDFLAGS+=-lm option to the end.
+The order of the math library directive '-lm' matters.
+
+Signed-off-by: Yuvaraj Patil <yuvaraj.patil@wipro.com>
+---
+diff -Nurp httping-2.3.4_orig/Makefile httping-2.3.4/Makefile
+--- httping-2.3.4_orig/Makefile 2014-07-23 16:16:36.495546288 +0530
++++ httping-2.3.4/Makefile 2014-07-23 16:18:42.547541002 +0530
+@@ -37,7 +37,6 @@ DEBUG=yes
+ WFLAGS=-Wall -W
+ OFLAGS=
+ CFLAGS+=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\" -DLOCALEDIR=\"$(LOCALEDIR)\"
+-LDFLAGS+=-lm
+
+ PACKAGE=$(TARGET)-$(VERSION)
+ PREFIX?=/usr
+@@ -97,6 +96,8 @@ ifeq ($(ARM),yes)
+ CC=arm-linux-gcc
+ endif
+
++LDFLAGS+=-lm
++
+ all: $(TARGET) $(TRANSLATIONS)
+
+ $(TARGET): $(OBJS)