summaryrefslogtreecommitdiff
path: root/package/ibrdtn-tools
diff options
context:
space:
mode:
authorTom Sparks <tom_a_sparks@yahoo.com.au>2015-08-09 10:00:19 +1000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-29 22:59:14 +0200
commit0b22622fecfc35737a7dd3933a7116f7c06cbf8c (patch)
treeeba863304030667c3fb0a39628fa8f10ec6af4fc /package/ibrdtn-tools
parentc6551d8199b8ee17035636832e2d816152ee697e (diff)
ibrdtn-tools: new package
[Thomas: - include package/ibrdtn-tools/Config.in from package/Config.in - fix the Config.in option name: we don't use - in option names, it should be replaced by _. Also do the same change in the .mk file. - from Config.in, don't select BR2_PACKAGE_IBRDTND (it's not a dependency of ibrdtn-tools), but instead select BR2_PACKAGE_IBRCOMMON and BR2_PACKAGE_IBRDTN. - in the Config.in file, fix the comment dependency logic (we want the comment to be shown when either thread support *or* C++ support is missing) - add hash file. - do not install to staging, since the package does not install any library - remove IBRDTN_TOOLS_SOURCE variable, since it's equal to the default value - add ibrcommon, ibrdtn and host-pkgconf as mandatory dependencies, and handle libdaemon and libarchive as optional dependencies. - remove custom INSTALL_STAGING_OPTS and INSTALL_TARGET_OPTS: automake is used, so there's no need for any hack.] Signed-off-by: Tom Sparks <tom_a_sparks@yahoo.com.au> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/ibrdtn-tools')
-rw-r--r--package/ibrdtn-tools/Config.in15
-rw-r--r--package/ibrdtn-tools/ibrdtn-tools.hash2
-rw-r--r--package/ibrdtn-tools/ibrdtn-tools.mk27
3 files changed, 44 insertions, 0 deletions
diff --git a/package/ibrdtn-tools/Config.in b/package/ibrdtn-tools/Config.in
new file mode 100644
index 000000000..91419d676
--- /dev/null
+++ b/package/ibrdtn-tools/Config.in
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_IBRDTN_TOOLS
+ bool "ibrdtn-tools"
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ select BR2_PACKAGE_IBRCOMMON
+ select BR2_PACKAGE_IBRDTN
+ help
+ IBR-DTN is a small dtn application that supports:
+ Bundle Protocol RFC 5050
+ Bundle Security Protocol RFC 6257
+
+ http://trac.ibr.cs.tu-bs.de/project-cm-2012-ibrdtn
+
+comment "ibrdtn-tools needs a toolchain w/ C++, threads"
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/ibrdtn-tools/ibrdtn-tools.hash b/package/ibrdtn-tools/ibrdtn-tools.hash
new file mode 100644
index 000000000..fb7720752
--- /dev/null
+++ b/package/ibrdtn-tools/ibrdtn-tools.hash
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 eab066cf15f9c322d769c6c9c58adfb474cba7d446fd12e8de5ff6344376795b ibrdtn-tools-1.0.1.tar.gz
diff --git a/package/ibrdtn-tools/ibrdtn-tools.mk b/package/ibrdtn-tools/ibrdtn-tools.mk
new file mode 100644
index 000000000..c9a585d92
--- /dev/null
+++ b/package/ibrdtn-tools/ibrdtn-tools.mk
@@ -0,0 +1,27 @@
+################################################################################
+#
+# ibrdtn-tools
+#
+################################################################################
+
+IBRDTN_TOOLS_VERSION = 1.0.1
+IBRDTN_TOOLS_SITE = https://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases/
+IBRDTN_TOOLS_LICENSE = Apache-2.0
+IBRDTN_TOOLS_LICENSE_FILES = COPYING
+IBRDTN_TOOLS_DEPENDENCIES = ibrcommon ibrdtn host-pkgconf
+
+ifeq ($(BR2_PACKAGE_LIBDAEMON),y)
+IBRDTN_TOOLS_CONF_OPTS += --with-libdaemon
+IBRDTN_TOOLS_DEPENDENCIES += libdaemon
+else
+IBRDTN_TOOLS_CONF_OPTS += --without-libdaemon
+endif
+
+ifeq ($(BR2_PACKAGE_LIBARCHIVE),y)
+IBRDTN_TOOLS_CONF_OPTS += --with-libarchive
+IBRDTN_TOOLS_DEPENDENCIES += libarchive
+else
+IBRDTN_TOOLS_CONF_OPTS += --without-libarchive
+endif
+
+$(eval $(autotools-package))