summaryrefslogtreecommitdiff
path: root/package/ipmitool
diff options
context:
space:
mode:
authorFloris Bos <bos@je-eigen-domein.nl>2014-09-12 01:12:48 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-09-13 21:57:03 +0200
commit2900d48ab8dd182e32db4282b10ebbebc0a77029 (patch)
tree4aee87950ae8737d2c481b2cc5e1698bb3870e88 /package/ipmitool
parent4c443f0247bde405e57e8b7db078a56a7cf9130a (diff)
ipmitool: new package
Adds ipmitool, a command-line interface to IPMI-enabled devices. Signed-off-by: Floris Bos <bos@je-eigen-domein.nl> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/ipmitool')
-rw-r--r--package/ipmitool/Config.in26
-rw-r--r--package/ipmitool/ipmitool.mk30
2 files changed, 56 insertions, 0 deletions
diff --git a/package/ipmitool/Config.in b/package/ipmitool/Config.in
new file mode 100644
index 000000000..e9b5374ea
--- /dev/null
+++ b/package/ipmitool/Config.in
@@ -0,0 +1,26 @@
+config BR2_PACKAGE_IPMITOOL
+ bool "ipmitool"
+ depends on BR2_USE_MMU # fork()
+ help
+ IPMItool provides a simple command-line interface to IPMI-enabled devices.
+
+ http://sourceforge.net/projects/ipmitool/
+
+if BR2_PACKAGE_IPMITOOL
+
+config BR2_PACKAGE_IPMITOOL_LANPLUS
+ bool "enable lanplus interface"
+ select BR2_PACKAGE_OPENSSL
+ help
+ Enables the IPMI v2.0 RMCP+ LAN interface typically used to send IPMI
+ commands to the BMC of a remote server.
+ Not needed if you only want to communicate with the local BMC of your
+ device using the OpenIPMI ipmi_si kernel module, or if using the
+ legacy IPMI v1.5 RMCP LAN interface.
+
+config BR2_PACKAGE_IPMITOOL_IPMIEVD
+ bool "ipmievd"
+ help
+ IPMI event daemon for sending events to syslog
+
+endif
diff --git a/package/ipmitool/ipmitool.mk b/package/ipmitool/ipmitool.mk
new file mode 100644
index 000000000..85be88326
--- /dev/null
+++ b/package/ipmitool/ipmitool.mk
@@ -0,0 +1,30 @@
+################################################################################
+#
+# ipmitool
+#
+################################################################################
+
+IPMITOOL_VERSION = 1.8.14
+IPMITOOL_SOURCE = ipmitool-$(IPMITOOL_VERSION).tar.bz2
+IPMITOOL_SITE = http://downloads.sourceforge.net/project/ipmitool/ipmitool/$(IPMITOOL_VERSION)
+IPMITOOL_LICENSE = BSD-3c
+IPMITOOL_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_PACKAGE_IPMITOOL_LANPLUS),y)
+IPMITOOL_DEPENDENCIES += openssl
+else
+IPMITOOL_CONF_OPT += --disable-intf-lanplus
+endif
+
+ifeq ($(BR2_PACKAGE_READLINE),y)
+IPMITOOL_DEPENDENCIES += readline
+endif
+
+ifeq ($(BR2_PACKAGE_IPMITOOL_IPMIEVD),)
+define IPMITOOL_REMOVE_IPMIEVD
+ $(RM) -f $(TARGET_DIR)/usr/sbin/ipmievd
+endef
+IPMITOOL_POST_INSTALL_TARGET_HOOKS += IPMITOOL_REMOVE_IPMIEVD
+endif
+
+$(eval $(autotools-package))