summaryrefslogtreecommitdiff
path: root/package/ipsec-tools
diff options
context:
space:
mode:
authorDoug Kehn <rdkehn@yahoo.com>2015-01-31 23:26:52 -0600
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-02-01 23:24:55 +0100
commit9849366388f9695b2aa532302ab67dcc47c8924d (patch)
treecd8386577d51e4505bd1ba321a5ea431f68fcb59 /package/ipsec-tools
parent7b5ff1ab8ae6c9de6e8f6c0355d80255ae344efe (diff)
package/ipsec-tools: hybrid config support
Add config option for enabling hybrid mode. Hybrid mode is required for successful interoperability. Signed-off-by: Doug Kehn <rdkehn@yahoo.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/ipsec-tools')
-rw-r--r--package/ipsec-tools/Config.in6
-rw-r--r--package/ipsec-tools/ipsec-tools.mk7
2 files changed, 12 insertions, 1 deletions
diff --git a/package/ipsec-tools/Config.in b/package/ipsec-tools/Config.in
index a0d760025..4af409584 100644
--- a/package/ipsec-tools/Config.in
+++ b/package/ipsec-tools/Config.in
@@ -48,6 +48,12 @@ config BR2_PACKAGE_IPSEC_TOOLS_READLINE
select BR2_PACKAGE_READLINE
bool "Enable readline input support"
+config BR2_PACKAGE_IPSEC_TOOLS_HYBRID
+ bool "Enable hybrid, both mode-cfg and xauth support"
+ help
+ Hybrid mode is required for successful interoperability
+ (e.g. Cisco VPN Client).
+
choice
prompt "Security context"
default BR2_PACKAGE_IPSEC_SECCTX_DISABLE
diff --git a/package/ipsec-tools/ipsec-tools.mk b/package/ipsec-tools/ipsec-tools.mk
index d9160277d..56e2bed7f 100644
--- a/package/ipsec-tools/ipsec-tools.mk
+++ b/package/ipsec-tools/ipsec-tools.mk
@@ -21,7 +21,6 @@ IPSEC_TOOLS_CONF_ENV += LIBS=-lz
endif
IPSEC_TOOLS_CONF_OPTS = \
- --disable-hybrid \
--without-libpam \
--disable-gssapi \
--with-kernel-headers=$(STAGING_DIR)/usr/include
@@ -62,6 +61,12 @@ else
IPSEC_DEPENDENCIES += readline
endif
+ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_HYBRID), y)
+IPSEC_TOOLS_CONF_OPTS += --enable-hybrid
+else
+IPSEC_TOOLS_CONF_OPTS += --disable-hybrid
+endif
+
ifeq ($(BR2_PACKAGE_IPSEC_SECCTX_DISABLE),y)
IPSEC_TOOLS_CONF_OPTS += --enable-security-context=no
endif