summaryrefslogtreecommitdiff
path: root/package/iptables
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-01-06 10:25:38 -0300
committerPeter Korsgaard <peter@korsgaard.com>2016-02-02 12:27:59 +0100
commit85a28f392783cf6b80881be02609c6df460e1dab (patch)
treef2378fd3b2b7a123b327241eb0ea963aa248c0c2 /package/iptables
parent8424a6ad6ad4d3828312a4a1b357ba08f911d8f1 (diff)
iptables: fix libpcap static linking
libpcap can depend on other libraries like libusb and doesn't support pkgconfig, so add those libraries to LIBS when building statically. Fixes: http://autobuild.buildroot.net/results/b4a/b4a3d00e9673a7aacc663c81de1d8e887a17951d/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/iptables.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/iptables/iptables.mk b/package/iptables/iptables.mk
index 77a9fad62..12e00f238 100644
--- a/package/iptables/iptables.mk
+++ b/package/iptables/iptables.mk
@@ -38,6 +38,11 @@ endif
# bpf compiler support and nfsynproxy tool
ifeq ($(BR2_PACKAGE_IPTABLES_BPF_NFSYNPROXY),y)
+# libpcap is tricky for static-only builds and needs help
+ifeq ($(BR2_STATIC_LIBS),y)
+IPTABLES_LIBS_FOR_STATIC_LINK += `$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs`
+IPTABLES_CONF_OPTS += LIBS="$(IPTABLES_LIBS_FOR_STATIC_LINK)"
+endif
IPTABLES_CONF_OPTS += --enable-bpf-compiler --enable-nfsynproxy
IPTABLES_DEPENDENCIES += libpcap
else