summaryrefslogtreecommitdiff
path: root/package/iucode-tool
diff options
context:
space:
mode:
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>2014-02-04 10:25:58 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-04 15:53:57 +0100
commit3f2d43e3ed631d803fb7b9eadbdb18a5b79d5b63 (patch)
tree410deb69f3c2a333fef8262ef9b2396d9f46bbbe /package/iucode-tool
parent170d526e91ae5249647e60d5b845468aa6c561c0 (diff)
iucode-tools: new package
iucode_tool is a program to manipulate IntelĀ® X86 and X86-64 processor microcode collections, and to use the kernel facilities to upgrade the microcode on Intel system processors. It was originally sent by Richard Braun <rbraun@sceen.net> [Peter: drop 'sid' from upstream URL] Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Cc: Richard Braun <rbraun@sceen.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/iucode-tool')
-rw-r--r--package/iucode-tool/Config.in8
-rw-r--r--package/iucode-tool/S00iucode-tool23
-rw-r--r--package/iucode-tool/iucode-tool.mk19
3 files changed, 50 insertions, 0 deletions
diff --git a/package/iucode-tool/Config.in b/package/iucode-tool/Config.in
new file mode 100644
index 000000000..19e225411
--- /dev/null
+++ b/package/iucode-tool/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_IUCODE_TOOL
+ bool "iucode-tool"
+ depends on BR2_x86_64 || BR2_i386
+ select BR2_PACKAGE_INTEL_MICROCODE
+ help
+ Intel processor microcode tool
+
+ http://packages.debian.org/source/iucode-tool
diff --git a/package/iucode-tool/S00iucode-tool b/package/iucode-tool/S00iucode-tool
new file mode 100644
index 000000000..0c1e409de
--- /dev/null
+++ b/package/iucode-tool/S00iucode-tool
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# Upload microcode into the processor.
+#
+
+microcode_file="/usr/share/misc/intel-microcode.dat"
+
+case "$1" in
+ start)
+ echo "Starting iucode-tool:"
+ /usr/sbin/iucode_tool -k $microcode_file
+ echo "done"
+ ;;
+ stop)
+ ;;
+ restart|reload)
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+ exit 1
+esac
+
+exit $?
diff --git a/package/iucode-tool/iucode-tool.mk b/package/iucode-tool/iucode-tool.mk
new file mode 100644
index 000000000..2d52b16e7
--- /dev/null
+++ b/package/iucode-tool/iucode-tool.mk
@@ -0,0 +1,19 @@
+################################################################################
+#
+# iucode-tool
+#
+################################################################################
+
+IUCODE_TOOL_VERSION = v1.0.1
+IUCODE_TOOL_SITE = git://git.debian.org/users/hmh/iucode-tool.git
+IUCODE_TOOL_AUTORECONF = YES
+IUCODE_TOOL_LICENSE = GPLv2+
+IUCODE_TOOL_LICENSE_FILES = COPYING
+
+define IUCODE_TOOL_INSTALL_INIT_SYSV
+ [ -f $(TARGET_DIR)/etc/init.d/S00iucode-tool ] || \
+ $(INSTALL) -D -m 0755 package/iucode-tool/S00iucode-tool \
+ $(TARGET_DIR)/etc/init.d/S00iucode-tool
+endef
+
+$(eval $(autotools-package))