summaryrefslogtreecommitdiff
path: root/package/iucode-tool
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-01-22 10:06:05 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-01-22 10:08:29 +0100
commit6a774f400b20612cb77836a47aaf62ea72422fb8 (patch)
treefccc40c40ac256af555a160aa0e93e085680f55a /package/iucode-tool
parent3fc77e5f81906d774be2710b16166fca48fb3e05 (diff)
iucode-tool: argp-standalone also needed with musl
The iucode-tool package needs the argp functionality, which is provided built-in by glibc, but not by uClibc and musl. In uClibc configurations, it correctly selects the argp-standalone package to compensate this, but forgets to do so in musl-based configurations. This commit fixes that by selecting the argp-standalone package, and adjusting the dependency in the .mk file. Fixes: http://autobuild.buildroot.net/results/7f8626db69500a84a393053a485f04180c565673/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/iucode-tool')
-rw-r--r--package/iucode-tool/Config.in3
-rw-r--r--package/iucode-tool/iucode-tool.mk2
2 files changed, 3 insertions, 2 deletions
diff --git a/package/iucode-tool/Config.in b/package/iucode-tool/Config.in
index b996b36d3..aeb3b6e31 100644
--- a/package/iucode-tool/Config.in
+++ b/package/iucode-tool/Config.in
@@ -2,7 +2,8 @@ config BR2_PACKAGE_IUCODE_TOOL
bool "iucode-tool"
depends on BR2_x86_64 || BR2_i386
select BR2_PACKAGE_INTEL_MICROCODE
- select BR2_PACKAGE_ARGP_STANDALONE if BR2_TOOLCHAIN_USES_UCLIBC
+ select BR2_PACKAGE_ARGP_STANDALONE \
+ if BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_MUSL
help
Intel processor microcode tool
diff --git a/package/iucode-tool/iucode-tool.mk b/package/iucode-tool/iucode-tool.mk
index 44d49d9e9..30515f0f8 100644
--- a/package/iucode-tool/iucode-tool.mk
+++ b/package/iucode-tool/iucode-tool.mk
@@ -6,7 +6,7 @@
IUCODE_TOOL_VERSION = 1cbd73013cd4c6b2b287f07f6189eef35cb83ca0
IUCODE_TOOL_SITE = git://gitorious.org/iucode-tool/iucode-tool.git
-ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
IUCODE_TOOL_CONF_ENV = LIBS="-largp"
IUCODE_TOOL_DEPENDENCIES = argp-standalone
endif