summaryrefslogtreecommitdiff
path: root/package/iw
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-07 12:40:22 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-15 18:09:25 +0100
commit466a3aa661efb1e90d9ab06a2c83a22b7f1c8b76 (patch)
treebe86745c0440c67d0acb4fcf70d5b69f91ef01c3 /package/iw
parent1826371d1fa3e49e8fa659b3037b05911f749749 (diff)
iw: simplify static linking handling
Now that libnl pkg-config file is correct, there is no need to have special handling for static linking in the iw package: it already uses pkg-config to get the necessary flags to link with libnl. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/iw')
-rw-r--r--package/iw/iw.mk6
1 files changed, 0 insertions, 6 deletions
diff --git a/package/iw/iw.mk b/package/iw/iw.mk
index df6e25711..1286915a6 100644
--- a/package/iw/iw.mk
+++ b/package/iw/iw.mk
@@ -14,12 +14,6 @@ IW_MAKE_OPTS = CC="$(TARGET_CC)" LD="$(TARGET_LD)" LDFLAGS="$(TARGET_LDFLAGS)"
IW_MAKE_ENV = PKG_CONFIG="$(HOST_DIR)/usr/bin/pkg-config" \
GIT_DIR=$(IW_DIR)
-ifeq ($(BR2_STATIC_LIBS),y)
-# libnl needs pthread/m, so we need to explicitly with them when static
-# these need to added AFTER libnl, so we have to override LIBS completely
-IW_MAKE_OPTS += LIBS='-lnl-genl-3 -lnl-3 -lpthread -lm'
-endif
-
define IW_BUILD_CMDS
$(IW_MAKE_ENV) $(MAKE) $(IW_MAKE_OPTS) -C $(@D)
endef