summaryrefslogtreecommitdiff
path: root/package/jamvm
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-12-04 10:02:25 -0800
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-04 10:21:45 -0800
commitae10e33a504770b0141dd7582c6ca26fc43b4642 (patch)
tree20e606cb70ca9228ebfa5ef02ae60d61c4135189 /package/jamvm
parent5062f530081913bd0487f0f879be180f30836ab8 (diff)
package: add jamvm jvm
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/jamvm')
-rw-r--r--package/jamvm/Config.in9
-rw-r--r--package/jamvm/jamvm.mk11
2 files changed, 20 insertions, 0 deletions
diff --git a/package/jamvm/Config.in b/package/jamvm/Config.in
new file mode 100644
index 000000000..852c6e89f
--- /dev/null
+++ b/package/jamvm/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_JAMVM
+ bool "jamvm"
+ select BR2_PACKAGE_ZLIB
+ select BR2_PACKAGE_CLASSPATH
+ help
+ JamVM is a new Java Virtual Machine which conforms to the
+ JVM specification version 2 (blue book).
+
+ http://jamvm.sf.net
diff --git a/package/jamvm/jamvm.mk b/package/jamvm/jamvm.mk
new file mode 100644
index 000000000..f0765d7cd
--- /dev/null
+++ b/package/jamvm/jamvm.mk
@@ -0,0 +1,11 @@
+JAMVM_VERSION = 1.5.4
+JAMVM_SITE = http://downloads.sourceforge.net/project/jamvm/jamvm/JamVM%20$(JAMVM_VERSION)
+JAMVM_DEPENDENCIES = zlib classpath
+# int inlining seems to crash jamvm, don't build shared version of internal lib
+JAMVM_CONF_OPT = \
+ --with-classpath-install-dir=/usr \
+ --disable-int-inlining \
+ --disable-shared \
+ --without-pic
+
+$(eval $(autotools-package))