summaryrefslogtreecommitdiff
path: root/package/janus-gateway
diff options
context:
space:
mode:
authorAdam Duskett <Aduskett@gmail.com>2017-01-25 08:42:40 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-01-28 21:39:40 +1300
commit75175e4cd7cdc097d0b4d8bc1f67506d69e7b3b0 (patch)
tree849bd0eb0f3818f2a643baa6c2e9fac78859c142 /package/janus-gateway
parent164bba50a6be0817a6b3aae671c280ea589e8cd9 (diff)
janus-gateway: make recordplay plugin optional
Currently janus-gateway is built by default with the record and play plugin. This causes a example config file to be placed on the target filing system that the user may not need or want, creates a 68K .so file on the target directory, and janus will also create a warning when ran if the plugin does not have a matching configuration file setup by the user, as it will not use the example config file by default. This patch makes the record and play plugin a option. Signed-off-by: Adam Duskett <aduskett@codeblue.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/janus-gateway')
-rw-r--r--package/janus-gateway/Config.in3
-rw-r--r--package/janus-gateway/janus-gateway.mk6
2 files changed, 9 insertions, 0 deletions
diff --git a/package/janus-gateway/Config.in b/package/janus-gateway/Config.in
index 39297a80d..c050edef8 100644
--- a/package/janus-gateway/Config.in
+++ b/package/janus-gateway/Config.in
@@ -26,6 +26,9 @@ config BR2_PACKAGE_JANUS_AUDIO_BRIDGE
config BR2_PACKAGE_JANUS_ECHO_TEST
bool "echo test"
+config BR2_PACKAGE_JANUS_RECORDPLAY
+ bool "record and play"
+
config BR2_PACKAGE_JANUS_SIP_GATEWAY
bool "sip gateway"
select BR2_PACKAGE_SOFIA_SIP
diff --git a/package/janus-gateway/janus-gateway.mk b/package/janus-gateway/janus-gateway.mk
index ce1239312..a051e582a 100644
--- a/package/janus-gateway/janus-gateway.mk
+++ b/package/janus-gateway/janus-gateway.mk
@@ -39,6 +39,12 @@ else
JANUS_GATEWAY_CONF_OPTS += --disable-plugin-echotest
endif
+ifeq ($(BR2_PACKAGE_JANUS_RECORDPLAY),y)
+JANUS_GATEWAY_CONF_OPTS += --enable-plugin-recordplay
+else
+JANUS_GATEWAY_CONF_OPTS += --disable-plugin-recordplay
+endif
+
ifeq ($(BR2_PACKAGE_JANUS_SIP_GATEWAY),y)
JANUS_GATEWAY_DEPENDENCIES += sofia-sip
JANUS_GATEWAY_CONF_OPTS += --enable-plugin-sip