summaryrefslogtreecommitdiff
path: root/package/janus-gateway
diff options
context:
space:
mode:
authorAdam Duskett <Aduskett@gmail.com>2017-01-25 08:42:36 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-01-28 21:39:35 +1300
commite942b7e731a697f1f77793a7adeb17c72bc411c9 (patch)
tree35f923850a906ab60f929b8409341a0c24377b4e /package/janus-gateway
parent994ac94c57bb422abc818674be4f9e04c8ff60ca (diff)
janus-gateway: remove unnecessary dependencies
janus-gateway currently depends on several dependencies that are not mandatory. This commit removes all non-mandatory dependencies. The build has been tested to work fine with this reduced set of dependencies. Signed-off-by: Adam Duskett <aduskett@codeblue.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/janus-gateway')
-rw-r--r--package/janus-gateway/Config.in7
-rw-r--r--package/janus-gateway/janus-gateway.mk4
2 files changed, 4 insertions, 7 deletions
diff --git a/package/janus-gateway/Config.in b/package/janus-gateway/Config.in
index 20491b794..b9a2c66b7 100644
--- a/package/janus-gateway/Config.in
+++ b/package/janus-gateway/Config.in
@@ -1,14 +1,11 @@
config BR2_PACKAGE_JANUS_GATEWAY
bool "janus-gateway"
- select BR2_PACKAGE_LIBMICROHTTPD
select BR2_PACKAGE_JANSSON
+ select BR2_PACKAGE_LIBGLIB2
select BR2_PACKAGE_LIBNICE
- select BR2_PACKAGE_SOFIA_SIP
select BR2_PACKAGE_LIBSRTP
select BR2_PACKAGE_OPENSSL
- select BR2_PACKAGE_DING_LIBS
- depends on BR2_PACKAGE_LIBGPG_ERROR_ARCH_SUPPORTS # libgcrypt, libmicrohttpd
- depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2, libmicrohttpd
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
depends on BR2_USE_WCHAR # libnice -> libglib2
depends on BR2_USE_MMU # libnice
depends on !BR2_STATIC_LIBS # dlopen
diff --git a/package/janus-gateway/janus-gateway.mk b/package/janus-gateway/janus-gateway.mk
index 4b87b33ae..1b8376819 100644
--- a/package/janus-gateway/janus-gateway.mk
+++ b/package/janus-gateway/janus-gateway.mk
@@ -10,8 +10,8 @@ JANUS_GATEWAY_LICENSE = GPLv3
JANUS_GATEWAY_LICENSE_FILES = COPYING
# ding-libs provides the ini_config library
-JANUS_GATEWAY_DEPENDENCIES = host-pkgconf libmicrohttpd jansson \
- libnice sofia-sip libsrtp host-gengetopt openssl ding-libs
+JANUS_GATEWAY_DEPENDENCIES = host-pkgconf jansson libnice \
+ libsrtp host-gengetopt libglib2 openssl
# Straight out of the repository, no ./configure, and we also patch
# configure.ac.