summaryrefslogtreecommitdiff
path: root/package/jasper
diff options
context:
space:
mode:
authorMax Filippov <jcmvbkbc@gmail.com>2015-05-19 21:29:00 +0300
committerPeter Korsgaard <peter@korsgaard.com>2015-05-19 21:36:18 +0200
commit71d9b0c1f06896f113b09e941aa84d979bff5710 (patch)
tree7e94702e449d1a01d838305ef50902e594344728 /package/jasper
parent4dcf9d14b5d6dc2f2e0f349756d17f8ffb99604e (diff)
jasper: Disable debugging when building for xtensa
xtensa gcc is not able to generate correct code when compiling with -O0 enabled by --enable-debug. Instead of disabling package build it with --disable-debug. Fixes: http://autobuild.buildroot.net/results/5d17055027055ffd33fcd28b208130afb26343c9/ Signed-off-by: Max Filippov <jcmvbkbc@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/jasper')
-rw-r--r--package/jasper/jasper.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/jasper/jasper.mk b/package/jasper/jasper.mk
index b2da07d76..db86ae88e 100644
--- a/package/jasper/jasper.mk
+++ b/package/jasper/jasper.mk
@@ -14,4 +14,10 @@ JASPER_LICENSE_FILES = LICENSE
# needed to fix rpath issue (http://autobuild.buildroot.net/results/307/307cac65287420252a5bb64715d9a1edd90e72fa/)
JASPER_AUTORECONF = YES
+# Xtensa gcc is unable to generate correct code with -O0 enabled by
+# --enable-debug. Allow package build but disable debug.
+ifeq ($(BR2_xtensa)$(BR2_ENABLE_DEBUG),yy)
+JASPER_CONF_OPTS += --disable-debug
+endif
+
$(eval $(autotools-package))