summaryrefslogtreecommitdiff
path: root/package/jimtcl
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-02-14 21:57:39 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-15 17:09:17 +0100
commit40f7068f11bdb9c80b8c39cd992fdddd889a12dd (patch)
treeb506986da8ce8c0f258e37c1afc30591b487e5ec /package/jimtcl
parente158dbf0bd50ea7f17d53fee23fccffc5c99c9fd (diff)
jimtcl: don't attempt to handle ccache internally
jimtcl tries to use 'ccache' (a non-buildroot host version) which may not exist on the host system. If ccache is enabled in buildroot, the compiler used by jimtcl is: ccache <buildroot>/.../ccache <buildroot>/.../<tuple>-gcc If ccache is not present on the host, this results in the build error: ccache <buildroot>/.../ccache <buildroot>/.../<tuple>-gcc -D_GNU_SOURCE -Wall -I. -fpic -pipe -Os -c -o jim-subcmd.o jim-subcmd.c make[1]: ccache: Command not found This patch passes 'CCACHE=none' to the 'configure' script, disabling the internal handling of ccache, so that ccache can be transparently passed through CC. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/jimtcl')
-rw-r--r--package/jimtcl/jimtcl.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/jimtcl/jimtcl.mk b/package/jimtcl/jimtcl.mk
index 53cddf945..1f2ea82db 100644
--- a/package/jimtcl/jimtcl.mk
+++ b/package/jimtcl/jimtcl.mk
@@ -38,7 +38,7 @@ endif
define JIMTCL_CONFIGURE_CMDS
(cd $(@D); \
- $(TARGET_CONFIGURE_OPTS) \
+ $(TARGET_CONFIGURE_OPTS) CCACHE=none \
./configure --prefix=/usr \
$(JIMTCL_SHARED) \
)