summaryrefslogtreecommitdiff
path: root/package/jsoncpp
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2015-03-08 13:01:23 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-15 18:54:49 +0100
commit3201c7746d7788f07237b0411535c5ed7a7ed60e (patch)
tree847737bcebff76832ba56db06fe5dbc1268d65b6 /package/jsoncpp
parent7b17bafc5d7948aff3059e058ada80ad1fc50500 (diff)
package/jsoncpp: new package
Needed for upcoming Kodi pctv/filmon PVR packages: https://github.com/kodi-pvr/pvr.pctv/blob/master/CMakeLists.txt#L11 https://github.com/kodi-pvr/pvr.filmon/blob/master/CMakeLists.txt#L11 [Thomas: - bump to 1.6.0 - change the license to "Public Domain or MIT" - wrap Config.in help text] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/jsoncpp')
-rw-r--r--package/jsoncpp/Config.in14
-rw-r--r--package/jsoncpp/jsoncpp.mk16
2 files changed, 30 insertions, 0 deletions
diff --git a/package/jsoncpp/Config.in b/package/jsoncpp/Config.in
new file mode 100644
index 000000000..3ec02e17d
--- /dev/null
+++ b/package/jsoncpp/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_JSONCPP
+ depends on BR2_INSTALL_LIBSTDCPP
+ bool "jsoncpp"
+ help
+ JsonCpp is a C++ library that allows manipulating JSON
+ values, including serialization and deserialization to and
+ from strings. It can also preserve existing comment in
+ unserialization/serialization steps, making it a convenient
+ format to store user input files.
+
+ https://github.com/open-source-parsers/jsoncpp
+
+comment "jsoncpp needs a toolchain w/ C++"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/jsoncpp/jsoncpp.mk b/package/jsoncpp/jsoncpp.mk
new file mode 100644
index 000000000..cfd3dd9b3
--- /dev/null
+++ b/package/jsoncpp/jsoncpp.mk
@@ -0,0 +1,16 @@
+################################################################################
+#
+# jsoncpp
+#
+################################################################################
+
+JSONCPP_VERSION = 1.6.0
+JSONCPP_SITE = $(call github,open-source-parsers,jsoncpp,$(JSONCPP_VERSION))
+JSONCPP_LICENSE = Public Domain or MIT
+JSONCPP_LICENSE_FILES = LICENSE
+JSONCPP_INSTALL_STAGING = YES
+
+JSONCPP_CONF_OPTS += \
+ -DJSONCPP_WITH_POST_BUILD_UNITTEST=OFF
+
+$(eval $(cmake-package))