summaryrefslogtreecommitdiff
path: root/package/kismet
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-21 15:48:42 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 18:21:21 +0100
commit46143f16834987dce379a88d98ce7068cabfe29f (patch)
treee6c6ce7242e49c231bc7883050337806acaca801 /package/kismet
parente0b2041d44c32c7c6b6730137b23e4b3208ee109 (diff)
package/kismet: add optional support for libcap
When libcap was compiled before, kismet will use it as optional dependency: $ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/kismet_server | grep NEEDED 0x0000000000000001 (NEEDED) Shared library: [libcap.so.2] [...] The build system offers no option to en-/disable libcap support: https://www.kismetwireless.net/gitweb/?p=kismet.git;a=blob;f=configure.ac;h=e874b10f3c1d56e2deb5e8adf4b8da4066fdde56;hb=HEAD#l635 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/kismet')
-rw-r--r--package/kismet/kismet.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/kismet/kismet.mk b/package/kismet/kismet.mk
index 64a0ab276..f4a28b86d 100644
--- a/package/kismet/kismet.mk
+++ b/package/kismet/kismet.mk
@@ -15,6 +15,10 @@ KISMET_LICENSE_FILES = debian/copyright
# We touch configure.in:
KISMET_AUTORECONF = YES
+ifeq ($(BR2_PACKAGE_LIBCAP),y)
+KISMET_DEPENDENCIES += libcap
+endif
+
ifeq ($(BR2_PACKAGE_PCRE),y)
KISMET_DEPENDENCIES += pcre
endif