summaryrefslogtreecommitdiff
path: root/package/kmod
diff options
context:
space:
mode:
authorMaxim Mikityanskiy <maxtram95@gmail.com>2015-01-19 18:14:02 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-26 22:47:51 +0100
commit10e6284b70b6246dcccf9bff756c5f2f934ec5ed (patch)
tree034fd6d7f6305c1364426aa64a60ab806e56f237 /package/kmod
parentafac57162f638e2799953fd8041d64ad383f41b9 (diff)
package: install bash-completion files only with bash
package/systemd, package/kmod, package/util-linux: don't install bash-completion files if bash is not selected to be installed. Otherwise, install bash-completion files. package/systemd: don't install zsh-completion files is zsh is not selected to be installed. Otherwise, install zsh-completion files. package/util-linux: don't install empty /usr/share/bash-completion/completions directory if bash is not going to be installed, and install bash-completion files if bash is selected to be installed. Signed-off-by: Maxim Mikityanskiy <maxtram95@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/kmod')
-rw-r--r--package/kmod/kmod.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/kmod/kmod.mk b/package/kmod/kmod.mk
index cc185c883..ff07c784b 100644
--- a/package/kmod/kmod.mk
+++ b/package/kmod/kmod.mk
@@ -64,6 +64,10 @@ else
KMOD_CONF_OPTS += --disable-tools
endif
+ifeq ($(BR2_PACKAGE_BASH),)
+KMOD_CONF_OPTS += --with-bashcompletiondir=
+endif
+
# We only install depmod, since that's the only tool used for the
# host.
define HOST_KMOD_INSTALL_TOOLS