summaryrefslogtreecommitdiff
path: root/package/kmod
diff options
context:
space:
mode:
authorMax Filippov <jcmvbkbc@gmail.com>2014-03-05 00:30:31 +0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-03-04 23:18:21 +0100
commit55c83179c4b30c9ec715a75297849abd74a63e05 (patch)
tree7993bbda289f54f067e2b5a5469057b8b5c9db1b /package/kmod
parent00ba92454a53687260d1cb415d8aaa153ec94c31 (diff)
kmod: disable --gc-sections ld option when building for xtensa
This is a workaround for the following ld issue exhibited by --gc-sections option, until a proper fix for binutils is ready: ld: BFD (GNU Binutils) 2.22 internal error, aborting at elf32-xtensa.c line 3374 in elf_xtensa_finish_dynamic_sections Fixes: http://autobuild.buildroot.org/results/97d/97d4c96d6f6cdc1ed4007456f4ab70be9dfa41b5/ Suggested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Max Filippov <jcmvbkbc@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/kmod')
-rw-r--r--package/kmod/kmod.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/kmod/kmod.mk b/package/kmod/kmod.mk
index f79a49284..46c8ea935 100644
--- a/package/kmod/kmod.mk
+++ b/package/kmod/kmod.mk
@@ -32,6 +32,11 @@ KMOD_DEPENDENCIES += xz
KMOD_CONF_OPT += --with-xz
endif
+# --gc-sections triggers a bug in the current Xtensa binutils
+ifeq ($(BR2_xtensa),y)
+KMOD_CONF_ENV += cc_cv_LDFLAGS__Wl___gc_sections=no
+endif
+
ifeq ($(BR2_PACKAGE_KMOD_TOOLS),y)
# add license info for kmod tools